
Operation Manual for
Bartsoft for Windows CE (Mobile version)



BARTINGTON INSTRUMENTS

	 Page 2 of 2 	 OM2518/1

Table of Contents

Table of Figures	 3

1. About this Manual	 4

1.1. Symbols Glossary	 4

1.2. Running Windows-based Applications	 4

2. Introduction	 4

3. Installation	 5

3.1. Introduction	 5

3.2. Software Compatibility	 5

3.3. Installing Bartsoft CE to your Mobile Device	 5

3.4. Un-Installing BartsoftCE	 6

3.5. How to Install ActiveSync	 7

3.6. Installation Troubleshooting	 9

4. Quick Start Guide	 9

4.1. Introduction	 9

4.2. Running BartsoftCE and Connecting to an MS3 Device	 10

4.3. Taking Measurements	 10

5. The Bartsoft CE User Interface	 12

5.1. Bartsoft Menu Items	 12

5.2. Document Settings Menu	 14

5.3. The Table Menu	 15

5.4. Bartsoft Bars	 16

5.5. Bartsoft Device Interface	 17

5.6. Report Creation	 19

5.7. Taking Measurements	 33

5.8 The Bartsoft Report Screen	 37

6. Troubleshooting and Tips	 47

6.1. Connecting a Bartington MS3 device to a hand-held device	 47

6.2. How to take a simple measurement without any file or program 
configured	 47

6.3. Manually creating a measurement record	 47

6.4. How to clear the error status, displayed at the top of the application 
window	 48

6.5. How to Save As/Export an existing document as a different file format	
48

6.6. GPS Troubleshooting	 48

6.7 Other 	 48

Appendix A: Correction Algorithm	 49

Appendix B: Conversions from cgs to SI	 50



BARTINGTON INSTRUMENTS

	 Page 3 of 54 	 OM2518/1

Table of Figures

Figure 1: Choosing an installation location� 6

Figure 2: Remove programs� 6

Figure 3: Remove Bartsoft CE� 7

Figure 4: A Windows Mobile device connection is detected� 8

Figure 5: Windows Mobile device is connected.� 8

Figure 6: Transfering the installable CAB file to the device.� 9

Figure 7: Table menu is displayed after pressing and holding on the table� 16

Figure 8: Main interface tab � 18

Figure 9: Device information tab for MS3 meters� 19

Figure 10: Creating a new report� 20

Figure 11: The Settings menu� 21

Figure 12: Report type settings� 21

Figure 13: Correction settings� 23

Figure 14: Correction algorithms table� 24

Figure 15: Table properties� 26

Figure 16: Graph settings� 27

Figure 17: Grid settings� 28

Figure 18: Automatic position increment� 29

Figure 19: An example protocol of measurements� 31

Figure 20: Numbering format settings� 32

Figure 21: Down-hole settings� 33

Figure 22: The GPS window� 34

Figure 23: The Measurement window (List view)� 35

Figure 24: Measurement Start window� 36

Figure 25: Blank measurement� 36

Figure 26: Sample measurement� 37

Figure 27: Measurement progress bar� 37

Figure 28: First sample measurement in the list view� 38

Figure 29: Manual Entry window� 39

Figure 30: Table of measurements � 40

Figure 31: Merging multiple measurements� 42

Figure 32: The Statistics window� 44

Figure 33: 2D graph� 46

Figure 34: Grid graph� 46

Figure 35: Save changes prompt� 48

Figure 36: The load screen� 48

Figure 37: Bartsoft document (report) breakdown� 49



BARTINGTON INSTRUMENTS

	 Page 4 of 54 	 OM2518/1

1. About this Manual

This manual provides the information necessary to help customers operate Bartsoft software 
from Bartington Instruments.

Bartsoft Mobile can be run on a Windows CE compatible device, with a USB port that can 
provide power and so can act as a host to an MS3 Meter. It is provided free of charge with the 
Bartington Instruments MS3 meter and is designed for operation with any of the sensors from 
the Bartington MS2 range. 

The device recommended for use by Bartington Instruments is the Trimble Nomad. This is used 
as the example device in this manual.

For operation of the MS2 sensors, see OM0408 MS2 Magnetic Susceptibility System, available on 
the MS2/MS3 product page of the Bartington Instruments website at www.bartington.com/ms3.
html.

1.1. Symbols Glossary

The following symbols used within this manual call your attention to specific types of 
information:

Note: Provides useful supporting information on how to make better use of your purchase.

1.2. Running Windows-based Applications

Names of applications and menu / command options are shown in bold type.

Sequences of instructions for running Windows- and Windows-based applications are shown 
with an arrow: →.

Hence, for example, Start→ Programs → BartsoftCE means ‘from the desktop, click on Start, 
then Programs, then BartsoftCE’.

Note: The user’s familiarity with different versions of the Windows operating system is 
assumed. Instructions decribed are for Windows Mobile 6 Classic and may vary slightly for 
alternate versions.

2. Introduction

Bartsoft Mobile software acquires, corrects, displays, stores and prints data using Bartington 
Instruments MS3 meters. This guide explains how to use the software and helps the user 
understand how it works, including the function of all controls and windows.

http://www.bartington.com/ms3.html
http://www.bartington.com/ms3.html
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3. Installation

3.1. Introduction

This section describes the installation process of the Bartsoft CE mobile software. 

Bartsoft for Windows CE is available for download from the Bartington Instruments website at 
www.bartington.com/software.html. It is available as a single compressed file in ‘.CAB’ format. 
To install the application, this compressed file needs to be transferred onto the target Windows 
Mobile device and then run from the file location.

Note: Downloading from the website will ensure you always use the most up to date 
version.

3.2. Software Compatibility

Currently, this software is tested on Windows Mobile (PPC) Version 6 and should be compatible 
with Version 5 (both with touch screen). This software is not compatible with Microsoft 
Smartphone.

3.3. Installing Bartsoft CE to your Mobile Device

Please ensure that any previous versions of the application are uninstalled before starting. For 
instructions on how to remove an existing version of the software, see Un-Installing Bartsoft CE.

1. Create a copy of the installable CAB file on the device. There are two ways of transferring this 
file onto the device:

•	 The CAB file can be stored on a Storage Card (e.g. SD Card) and transferred to the device.

•	 A host PC can be used to copy the installable file directly onto the device using Microsoft 
ActiveSync. To download and install this software, see How to Install ActiveSync.

2. Run the CAB file to install BARTSOFT CE. 

When there is a Storage Card on the device, you will be prompted to choose the destination.

Note: It is strongly recommended that the application is installed on the device (not on the 
Storage Card). See Figure 1.

http://www.bartington.com/software.html
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Figure 1: Choosing an installation location

It is recommended that after the completion of a successful installation, the CAB file is removed 
from the device and the device is re-started.

3.4. Un-Installing BartsoftCE

In order to un-install Bartsoft you will need to use the ‘Remove Programs’ section of the settings 
menu. Navigate to : Start → Settings → ‘System’ Tab → Remove Programs. See Figure 2.

Figure 2: Remove programs
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You should then highlight the Bartsoft CE application as shown in Figure 3, before selecting 
the ‘Remove’ button to uninstall it from the device.

 

Figure 3: Remove Bartsoft CE

3.5. How to Install ActiveSync

ActiveSync is used to browse and transfer files and software to a mobile device through your PC. 
It can be downloaded from the Microsoft website at www.microsoft.com. 

If using Windows 7 or above, Windows Mobile Device Centre will install when the mobile device 
is connected and an internet connection is available. This acts in the same way as ActiveSync in 
previous Windows versions. 

After installing ActiveSync, the application should detect the mobile device that is connected via 
USB cable. For this purpose, you could choose to cancel the window in Figure 4, in order to skip 
the device synchronization. 
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Figure 4: A Windows Mobile device connection is detected

When the device is connected, the window in Figure 5 will be displayed. Select the ‘Explore’ 
button to browse the device content.

Figure 5: Windows Mobile device is connected.

Figure 6 shows the browser window. The BartsoftCE .CAB file should be copied to a location on 
the mobile device using this window. It can then be accessed directly through the device in order 
to perform the installation.
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Figure 6: Transfering the installable CAB file to the device.

3.6. Installation Troubleshooting

3.6.1. Bartsoft Will Not Start

If the Bartsoft CE application will not start then it is probable that the installation was 
unsuccessful. It is recommended that the application be un-installed and the .CAB file reloaded. 

If it still fails then the BartsoftCE .CAB file should be re-downloaded from the Bartington 
Instruments website, and transferred to the device. Installation should then be attempted again 
with the new file.

3.6.2. Application Starts But Cannot Detect the Connected MS3 Device

It is important not to connect the MS3 before the mobile device has been switched on. If this 
occurs then the device will need to be reset, and the MS3 plugged in once it has fully loaded.

Check the USB cable and connectors for signs of wear. Force should not be put on the USB 
connection: e.g. do not let the MS3 hang freely from the USB.

3.6.3 Connection Limitations

Note: The current version of Bartsoft CE can connect to MS3 devices via USB only. RS-232 
connection is not supported.

Note: Bartsoft CE is only compatible with MS3 devices. It is not possible to connect to an 
MS2 device.

3.6.3 Other Issues

If either of these problems persist, or if other problems are encountered, please contact 
Bartington Instruments Customer Services, support@bartington.com.

4. Quick Start Guide

4.1. Introduction

This section explains the basics of the Bartsoft application and its use. It is assumed that 
Bartsoft CE is installed and working. For installation and troubleshooting, refer to Installation.
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4.2. Running BartsoftCE and Connecting to an MS3 Device

At start-up, Bartsoft CE searches automatically for any connected MS3 devices via the 
application’s default port settings. 

Bartsoft displays the device status at the top left of the main window:

The application name ‘Bartsoft’ is followed by ‘1 OK’, when there is an MS3 device connected 
with a sensor attached ready for use. The status includes ‘Exx’ when there is an MS3 device 
connected but there is a communication error between the application and the MS3 device. The 
status includes ‘S!’ when there is an MS3 device connected but no sensor is detected.

The screen displayed after loading Bartsoft CE shows the default folder where previously saved 
reports will be displayed. 

Note: The MS3 should be connected after the mobile device has booted, not before. If 
the meter is connected beforehand, the device may require resetting before the MS3 is 
recognised.

4.3. Taking Measurements

Measurements can be taken when the application detects a meter device with a sensor attached 
to it.

Measurements can be taken in two different ways:

•	 Single measurement, using the device window in which the measurements are not recorded. 
(For more information see Bartsoft Device Interface.)

•	 according to a pre-defined program, where the records can be archived for later use.

4.3.1. Single Measurements

To take simple measurements, while the application’s main window is open:

1.	 Select Menu → Tools → Device from the main toolbar to display the quick measurement 
window.

2.	 Use the Main Interface tab containing the two Zero and Measure buttons on this window to 
take measurements.

Note: The device must be attached at the time. 

Note: Values displayed in this window are impromptu measurements and are not saved.

4.3.2. Controlling and Applying Corrections to Measurements
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To create an automatically controlled program for taking measurements that can be archived for 
later use, select New in the bottom left corner of the main screen to open the Report Creation 
Assistant and create a new data file, or open an existing file from the list.

Selecting Menu → Tools → Settings... opens the Settings wizard that lets the user configure a 
program for a specific device and sensor type.

This wizard lets the user set parameters that define how measurements are taken, how some 
calculations are carried out, and how the records are displayed. The available tabs are listed 
below:

•	 Report type: Select the type of survey to be performed and the sensor being used. Although 
a sensor can be selected which does not match the one being used, some corrections are 
particular to a type of sensor. The default measurement program will also change based on 
this selection. The report name can be entered in this tab.

•	 Correction selection: Select the drift correction and all other corrections applicable to the 
particular sensor being used. 

Note: Dual frequency measurement for the MS2B sensor can also be selected on this tab. 

•	 Table Properties: Select the information to be displayed during data collection. All data is 
recorded and kept in the file, and can be visualised when reopening the file.

•	 Program: Select the order in which measurements are to be made. The length of each 
measurement can also be changed here. If drift correction has been selected, the survey 
must finish with a blank measurement. There is always a blank measurement at the start, 
whether or not it is specified in this table. To remove a command from the list, select and 
hold down. To add new commands, select at the top of the page and press Add. For example, 
to select 10 sample measurements between each blank measurement, enter 10 in the 
Iterations box and then press Add. 

•	 Grid: This relates to core or grid survey and lets the user set up an automated increment 
for X & Y axes, allowing the user to lay out a gridded survey.  Selecting Log GPS data here 
will enable Bartsoft to record a GPS position against each measurement. This feature is only 
available on devices with GPS capability. 

•	 Depth: This tab is for use with the MS2H sensor and is used to define the increments of depth 
as it is lowered into a borehole. It might also be used for core measurement surveys.

•	 Format: Used to specify how you want the measurements to be displayed. The exponent and 
position of the decimal point can be selected. Units of SI or CGS are also selected here.

•	 Graph: This outlines options for the display of the graph created in the report. 

Note: Only the table or the graph can be displayed at one time, but you can alternate 
between the two.
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To finish configuring the report, click on OK to close the Report Settings window. 

For more detailed information on the Settings menu, see Report Creation.

The new report is now ready to receive and take measurements according to the configured 
program. It displays the acquired data and lets the user save the records, as well as the 
document configuration. (For more information see Taking Measurements and The Bartsoft 
Report Screen)

•	 The button labelled Start carries out the entire program, unless it is interrupted by clicking 
on the Stop button.

•	 The button labelled Start Single Cycle carries out one cycle of the program, unless it is 
interrupted.

Note: When the program is interrupted before the end of a cycle is reached, and drift 
correction is enabled (and unless the last measurement was a reference), then the 
application will carry out a reference (air) measurement before it stops.

5. The Bartsoft CE User Interface

The Bartsoft CE user interface allows the user to display, print and store data gathered from 
Bartington MS2 sensors. It includes the following groups of controls.

5.1. Bartsoft Menu Items

Menu items in Bartsoft CE will be greyed out if unavailable or irrelevant with current settings. 
Several options will only become available once a report has been started or opened.

Five different items are available in the Bartsoft CE Menu:

•	 File: Provides options for creating new reports, opening or saving reports, and for exiting the 
program.

•	 Edit: Provides data manipulation options: only available once a report has been opened.
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•	 View: Allows the user to look at statistics about the collected data: only available once a 
report has been opened.

•	 Tools: Contains commands that allow the user to take single measurements, view device 
information, and change the report settings; GPS information; and a manual data entry 
option.

•	 Help: A comprehensive help file that can be used in conjunction with this manual for 
information on the operation of Bartsoft CE. This section also contains version information.

5.1.1. File Menu

The File menu offers the following commands:

•	 New: Opens a new document. Alternatively, press the ‘New’ button on the hand side left of 
the Toolbar. 

•	 Open: Displays the file browser window, allowing the user to select a file. 

•	 Save: This menu item is only available when the File menu is accessed via an open document 
and the current document has changed since it was last saved. After selecting this menu 
item the open document is saved using the current name in the settings window (see “Report 
name”). 

•	 Save As...: Selecting this menu item opens the settings dialog where the report name can be 
changed before the document can be saved. This menu item is only available when accessed 
via an open document.

Note: The document type cannot be changed; i.e. it cannot be saved by any other type than 
‘.bid’. 

•	 Exit: Closes the application. If a document is open, the user is prompted to save the file.

Note: Selecting the cross button on the top right corner on the main application window 
will only hide the application (as a per standard behaviour of the Windows CE operating 
system). 

5.1.2. Edit Menu

The Edit menu is only available when a document is open and offers the following commands:

•	 Select All: Selects all records displayed on the list. If all records are selected then this item 
appears with a tick. Selecting this item, while ticked, de-selects all items.

•	 Delete → Selected: Prompts the user to delete the currently selected items from the list.

•	 Delete → All: Prompts the user to delete all items in the list.

•	 Copy → Selected: Prompts the user to copy the currently selected items from the list.
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•	 Copy → All Records: Prompts the user to copy all items in the list.

•	 Manage Repeats (all groups): This item allows averaging of selected list items, or removal of 
the smallest or largest item in a selection.

5.1.3. View menu

The View menu item is only available when a document is open. Selecting any of the sub-menu 
items displays the Statistics window.

•	 Statistics → Selected...: This menu item is only available when a number of items on the list 
are selected. 

•	 Statistics → All...: This menu item displays statistics for all items on the list. It is only 
available after at least one measurement has been taken. 

5.1.4. Tools Menu

The Tools menu contains the main functions of the Bartsoft CE program. The following 
commands are available:

•	 Device...: This menu item displays the Device window. 

•	 Settings...: This menu item displays the Settings window. 

•	 GPS...: This item  displays the GPS window. It becomes available when the tick-box Log GPS 
data is selected from the Grid Tab of the Settings window. 

•	 Manual entry...: This menu item displays the Manual Record Entry window. 

5.1.5. Help Menu

The Help menu offers the following commands:

•	 About...: This item displays version number and copyright information.

•	 Content: This menu item will display the Help Contents window.

5.2. Document Settings Menu

Open this window by selecting Tools → Settings... from the main menu.

Note: The Report type and Correction tabs can only be accessed when there is no 
document open, or there are no measurement records within a document. This is because 
any change to the type of sensor used for measurements, or the correction applied, needs 
to remain consistent for all items in the document. 

The following tabs are available in the Settings window:
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•	  Rep. type: selects the right sensor as well as the name and type of report. (For more 
information see Report Type Selection.)

•	  Program: selects how measurements will be gathered. (For more information see Program.)

•	  Grid: selects how position information is recorded with each new measurement. (For more 
information see Grid)

•	  Correction: selects which correction algorithms are applied to the measurements  (For 
more information see Correction Selection)

•	  Depth: selects increments in depth position with each new measurement if using the MS2H. 
(For more information see Depth)

•	  Format: selects the format in which numbers are displayed. (For more information see 
Numbering Format)

•	  Table prop: selects how measurements should be displayed within the table. (For more 
information see Table Properties)  

•	  Graph:  selects how measurements should be displayed within the graph. (For more 
information see Graph)

5.3. The Table Menu

The Table menu (Figure 7) is accessed by pressing and holding down on the table in the list view. 

Figure 7: Table menu is displayed after pressing and holding on the table
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The Table menu offers the following commands:

•	 Copy → Selected: Copies the selected measurements from the table into the clipboard. 

•	 Copy → All Records: Copies all measurements from the table into the clipboard. 

•	 Copy This Field: Copies only the item in the selected field into the clipboard.

Note: Once copied the measurements are then available to paste in any word- or table-
processing software.

•	 Edit → Edit Field: Allows some field values to be altered manually. 

Note: Susceptibility measurements cannot be changed using the Edit Field command.

•	 Edit → Delete Selected: Prompts the user to delete the currently selected items from the 
table.

•	 Edit → Delete All: Prompts the user to delete all items in the table.

•	 Edit → Select All: Selects all measurements in the table ready for further action.

•	 Statistics: Displays statistics including all recorded measurements or only those selected. 
(See Section 5.8.2.7 Statistics Window for more information.)

•	 Manage Repeats (pointed group): Allows averaging and removal of highest/lowest values in 
the selected group of repeats.

•	 Manage Repeats (all groups): Allows averaging and removal of highest/lowest values in the 
all groups of repeats. 

5.4. Bartsoft Bars

Three different types of access and information bars are available in Bartsoft:

•	 Status Bar: Informs the user of current actions by displaying help and software status.

•	 Toolbar: Provides quick access to the menu main functions.

•	 Scrollbars: Lets the user scroll the document or the table of measurement vertically and 
horizontally.

5.4.1. Status Bar

The status bar is displayed at the top of the Bartsoft window. This is displayed at all times when 
Bartsoft is being used.

The left end of the status bar indicates the status of the connected meter and sensor. The 
following status options can be displayed:
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•	 BartsoftWM: No meter is connected.

•	 Bartsoft 1 OK: An MS3 device is connected with a sensor attached ready for use. 

•	 Bartsoft Exx: An MS3 device is connected but there is a communication error between the 
application and the MS3 device. 

•	 Bartsoft S!: An MS3 device is connected but no sensor is detected. 

5.4.2. Toolbar

The toolbar is displayed across the bottom of the application window. The toolbar provides quick 
access to menu commands and is present at all times. 

•	 New: Start a new report.

•	 Menu: List of relevant menu options.

5.4.3. Scrollbars

The scrollbars appear automatically at the right and bottom edges of the document or table 
of measurements if they are required to see parts of the document table that are not directly 
visible.

5.5. Bartsoft Device Interface

5.5.1. Virtual Device Window

This window lets the user take measurements without having to create reports. It can be 
displayed by selecting Tools → Device... from the main menu. 

Note: Measurements taken using this interface are temporary and do not appear on the 
table of measurements or graph view. 

Note: Values displayed in this window are of measurements made in the present session 
and are not saved by the computer.

Since MS3 meters are able to take measurements with flexible time periods, the interface allows 
the user to set a measuring period between 0.1 seconds and 5 minutes.

The MS3 meter interface (Figure 8) has two tabs.

•	 Main Interface: Lets the user take quick measurements.

•	 Device Info: Displays information about the device.
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Figure 8: Main interface tab 

Main Interface

The main display provides controls to take measurements. The window consists of a display area 
for the last measured value (or zero, if the last request was an air measurement); the status of 
the meter; and the following controls.

•	 Status: Displays the current status of the device.

•	 CGS: If selected, the measurement value is displayed in cgs units. The default is SI units.

•	 Measuring Period: Selects the time duration (integration) for the measurement.

•	 Zero: Use this button to take an air measurement. The application stores the value obtained 
as a reference which is then used in calculations, after taking a sample measurement.

•	 Measure: Use this button to take a sample measurement.

Note: It is important to keep the same time period for an air measurement and its related 
sample measurement.

Device Info

This window (Figure 9) displays information about the device:

•	 A unique serial number to identify each device. Provide this number to Bartington 
Instruments if support is required.

•	 Hardware and software versions for the device.

•	 The Loader software version and Technician name. These are for use by Bartington 
Instruments.
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Figure 9: Device information tab for MS3 meters

5.6. Report Creation

5.6.1. Introduction

Report creation in Bartsoft CE is achieved by selecting New in the bottom left corner of the 
Bartsoft screen. All report options can the be set through use of the Tools → Settings... menu. 
Creating a report will log the data in tabular and graphical forms for later reference by the user. 

Note: Reports created in Bartsoft CE are fully compatible with the PC version of Bartsoft.

The first screen shown in Figure 10 is the load screen that is displayed when Bartsoft is first 
opened. The New option is circled in red. When this is selected the second screen will be 
displayed. This is the New Report screen. The Start option can only be selected once the report 
type has been specified in the Settings menu.

Figure 10: Creating a new report

5.6.2. Settings Window

Before a report can be carried out, the user must set up the report for their specific purpose. 
The Settings window shows the settings needed to create a report: The location of the Settings 
menu is shown in Figure 11.
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Figure 11: The Settings menu

The following options must be set before you can start your report:

•	 Rep. Type: This is the Report Type Selection tab where the type of report can be selected.

•	 Correction: Allows selection of the correction algorithm and any correction automation.

5.4.2.1. Report Type Selection

This screen (Figures 11 and 12) lets the user choose the type of report and sensor that is going 
to be used.
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Figure 12: Report type settings

Report name: Enter the report or file name here. Note that the entered file name should not 
include the file extension. The storage location for files is defined by the application. When 
memory card is used, then files are saved at: “\Storage Card\Bartsoft\”, while the path on the 
device is: “\My Documents\Bartsoft\” 

Comment: Used for notes or comments about the report or log-file. 

Use memory card: This tick-box is enabled when there is a memory card available on the device. 
Tick this control to use the memory card for file storage. 

Sensor type: Select the sensor type from the list of sensors displayed. The default is Drift Check.

Four report types are available:

•	 Individual sample study: Used for studying individual samples. 

•	 Core and down-hole survey: Used for studying cores or samples that are positioned linearly. 
A 2D graph that shows measurements in function of linear position or sample index can be 
displayed.

•	 Surface survey: Used for studying a surface that is mapped onto a grid. A grid that shows 
measurements as a function of (X, Y) position co-ordinates can be displayed.

•	 Drift Check: For making sure that the sensor environment is sufficiently quiet magnetically 
for taking measurements and/or making sure that the sensor is behaving consistently.

Note: While configuring a new report, the user must select a sensor type or the Drift 
Check option before the option to start is available.

Note: Selecting a sensor type resets some of the application configuration on the settings 
dialogue, without any warning. For example, the program list will be reset to a pre-defined 
sequence of measurements depending on the selected sensor type. 

5.6.2.2. Correction Selection

To measure the permeability of a sample to a high accuracy, the raw value obtained from the 
sensor needs to be corrected. The correction algorithm takes three major factors into account: 
temperature drift, the sample and sensor’s compatibility, and the susceptibility of the sample’s 
container. Figure 13 displays the Correction tab. Note that different options become available 
depending on the selected sensor type.
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Figure 13: Correction settings

Temperature Drift

Check the Apply Drift Correction box to select temperature drift correction. To take into account 
the effect of the temperature on the measurements, the permeability of the air is measured 
once before and once after the permeability of the sample itself. As temperature variation can 
be considered linear over a short period of time, the error in susceptibility measurements can 
be deduced and corrected, using the measured discrepancy between the first and the last air 
measurements.

Sample/Sensor Association

All Bartington Instruments sensors are designed to measure volumetric susceptibility 
accurately. However, the volume of a sample may not always be the same as the volume 
expected by the sensor. This difference must be accounted for. Bartsoft provides a list of 
correction algorithms depending on the type of sensor being used.

•	 ‘Volume specific correction’: when the container in which the sample is stored has a volume 
different from the volume of the provided calibration sample.

•	 ‘Height specific correction’: when all samples are stored in cylindrical containers of the same 
diameter but not all containers are filled to the same height.

•	 ‘Mass specific correction’: provided if if the volumetric susceptibility must be related to the 
density of the sample. All samples must be stored in containers of equal volume for this 
algorithm to be accurate.

•	 ‘Diameter specific correction’: when sample cores have varying diameters.

How to select the required correction type

The correction tab provides a list of correction types for specific sensors to let Bartsoft carry 
out the relevant corrective calculations. The available correction types depend on the selected 
sensor type. Figure 14 shows the available correction types for each sensor. (Bartsoft does not 
currently offer correction for other sensors.)

Correction Type MS2B MS2G MS2C

Volume √ √ ---
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Mass √ --- ---

Height --- √ ---

Diameter --- --- √

Figure 14: Correction algorithms table

Available configurations for different correction types are as follows:

Correction Type Options Instructions

Volume Use same volume for all 
samples

Tick this box when all 
containers used have the 
same volume, different 
to the calibration sample 
provided.

Untick the box to ensure 
that Bartsoft prompts the 
user to provide the volume 
of the sample’s container 
after each measurement is 
taken.

Volume of the sample in ml Enter the container’s 
volume, if the container 
used has a different volume 
to the reference volume.

Mass Empty container mass in g Enter the container’s mass. 
(The default value provided 
in the text box is the weight 
of the standard 10ml plastic 
sample pot.)

Volume of the sample in ml The same as above, where 
the selected correction type 
is volume specific.



BARTINGTON INSTRUMENTS

	 Page 24 of 54 	 OM2518/1

Height Use same height for all 
vials

Tick this box when all 
containers used have the 
same height, different to 
the height of the calibration 
sample provided.

Untick the box to ensure 
that the application prompts 
the user to provide the 
height of the sample’s 
container after each 
measurement is taken.

Sample fill height in mm Enter the height of the 
sample within the container.

Diameter Sensor’s diameter in mm Enter the sensor’s diameter 
in millimetres, if it is 
different from the provided 
default value.

Diameter of the core in mm Enter the diameter of the 
core to study in this box.

5.6.3. Optional Settings

The Optional Settings window includes settings that have been initialised with default values. 
These can be edited to adapt to the user’s particular needs.

•	 Table Properties: Selects how measurements should be displayed within the table.

•	 Graph: Selects how measurements should be displayed within the graph.

•	 Grid: Selects the way positions (X,Y) are assigned to each measurement, by an automatic grid 
or by GPS coordinates. 

•	 Program: Defines a measuring protocol that determines how measurements will be 
acquired.

•	 Format: Chooses a numbering notation: Scientific, Engineering or Fixed Exponent.

•	 Depth: Sets options for down-hole (Z) measurements.

5.6.3.1. Table Properties

This screen lets the user choose which fields (columns) are to be visible in the List view when 
taking measurements. The default selections are shown in Figure 15.
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If the width of the total number of columns to be displayed exceeds the width of the display area 
then a horizontal scrollbar will appear at the bottom of the table. 

Figure 15: Table properties

•	 ID: A string of characters used to name and recognise a measurement.

•	 Date & Time: The date and the time at which the measurement was stored in memory. Time 
is used as part of the Drift correction (if enabled).

•	 Position (XY): Information about where the measurement was taken. It is expressed in 
metres and displayed in X and Y components.

•	 GPS Position: Geographical information about where the measurement was taken.

Note: This information is applicable to grid reports and is only provided by Bartsoft running 
on a handheld mobile Windows CE platform with a connected GPS system.

•	 Depth (Z): Usually used for measurements taken from a core or within a borehole. Refers to 
the depth/point, where the measurement was taken and is expressed as the ‘Z’ component of 
the position.

•	 Corrected Meas.: The resultant value after applying corrections to the raw value. It includes 
all pre-set corrections. 

•	 Raw Meas.: The value as it has been measured, before any correction is applied to it.

•	 Correction factor/offset: Displays the type of correction, the corrective factor and the 
corrective offset that have been used to calculate the corrected value for the measurement.

•	 Sample variable (mass, fill, height...): Information about the sample measured. This is used 
to correct the raw value of the measurement.
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Note: Where the user can add any extra information about the measurement as text.

5.6.3.2. Graph

This screen (Figure 16) lets the user choose the type of graph, 2D or grid, that is to be displayed 
in the report, as well as the colour scheme applied to it. Only one graph is available in any one 
report.

•	 The 2D graph shows corrected measurements (Y axis) versus sample order, position (X or Y) 
or depth (X axis). Select this type of graph by checking the Line view check-box.

•	 The Grid shows corrected measurement (cell colour) versus position X (X axis) and position 
Y (Y axis). If a coordinate has no related measurement attached to it then it is filled with 
the graph background colour. The pitch of the grid is calculated in function of the minimum 
coordinate spacing between two consecutive positions (X and Y independently). Select this 
type of graph by checking the Grid view check-box.

Note: When viewing the report, only the table or the graph can be displayed at any one 
time. The user can alternate between the two using the Graph/List button..

Figure 16: Graph settings

Graph Colours: The graph colours can be selected using the drop-down lists.

5.6.3.3. Grid

The Grid tab (Figure 17) is used to relate position information to data collected. This is done 
either by assigning grid values, or by using GPS to take coordinates for each measurement.
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Figure 17: Grid settings

The Automatic grid settings become available when the selected report type is Surface survey 
and Automatic grid is ticked.

The available settings are as follows:

•	 Start position on the grid: The X and Y position on the grid, where the respective minimum 
values will be started.

•	 Position increment in metres: Value automatically added to the current X/Y values to 
calculate the next measurement position on the grid. For example the first measurement 
has the position equal to the values in Start position on the grid; the second measurement’s 
position is deduced by incrementing the X value of the current position on the grid by the X 
value defined in Position increment in metres (Figure 18).

Figure 18: Automatic position increment

•	 Number of measurements: The number of measurements on each axis is calculated as: 
(grid size / position increment) + 1 (the 1 is added to account for the measurement on the 
point of origin). Total number of measurements on a grid can be calculated by multiplying the 
X and Y fields of the Number of measurements. The values entered in these fields can only 
be positive whole numbers.

•	 Size of the grid: Calculated by multiplying the position-increment value by the number 
of measurements and deducting one from the result. If the user changes the X and Y size 
values then the application automatically updates the Number of measurements to keep the 
equation valid. Both of these values must be greater than 1 and less than 500.

GPS
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By ticking Log GPS Data the software will log a GPS coordinate next to each measurement taken. 
This is only possible when a suitable GPS device is incorporated into the mobile device. The 
measurements can then be displayed in a grid corresponding to these coordinates. 

•	 Log GPS Data: Select this option to enable GPS data recording on the device. The program 
will initialise the Windows Mobile GPS device driver that uses the currently active GPS device.

Note:  The operating system allows the user to choose one of potentially many GPS devices 
connected to the device. 

Note: Obtaining the initial GPS fix (connection) may take a few minutes and using the GPS 
window can help to ensure that there is a fix, before the measurement program is started.

The user will be warned if the measurement program is started before the GPS device has a 
successful fix.

5.6.3.4. Program

Here the user can set the measuring protocol, which defines how the measurements are carried 
out during the automatic measurement program.

Note: A protocol consists of one or more cycles. A typical cycle includes a list of different 
measurement types, where non-blank measurements may also be repeated more than 
once.

Note: Changing the sensor or report type will reset the program tab to the default 
measurement layout for that type.

Interface components

The interface (Figure 19) includes:

•	 Controls to help the user create and add measurements to the list of command/task(s):
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1.	 Command: list box to select the measurement type.

2.	 Meas. period: list box to select the measurement’s time period. A custom value can be 
entered by selecting the Manual Entry from the list and then entering a value followed 
by one of ‘s’, ‘m’ or ‘h’ (for seconds, minutes or hours). The value entered can contain a 
floating point (e.g. ‘6.5m’ for 6.5 minutes).

3.	 No of iterations: edit box to enter the number of times to repeat the measurement (not 
available for blank measurements).

4.	 Add button, to add the selected command to the list of tasks.

•	 Cycles: A box that contains the number of times the list of measurements should be 
repeated.

•	 List of Commands in each Cycle: A table that displays the current list of tasks as part of a 
cycle.

•	 Removing a command: To remove a command from the list, select the tick-box at the left 
side of the record, then press and hold the screen, before selecting ‘Remove Selected’ option 
from the menu that appears. To remove all commands, select ‘Remove All’ from the same 
menu. 
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Figure 19: An example protocol of measurements

In the first example in Figure 19, the application will take a blank measurement, followed by 
one sample measurement, repeating the cycle once. The second example shows one blank 
measurement, followed by 1000 sample measurements. 

Note: As magnetic susceptibility is derived from the measurement of relative permeability 
(permeability of sample/permeability of vacuum, which is approximated to the permeability 
of air measured by the meter during the zero or blank measurement step), cycles need to 
start with a blank measurement. Therefore, if a cycle does not start with a blank, it will be 
added automatically by the application.

Note: The setup wizard establishes whether a Drift Correction is required as part of a 
susceptibility measurement correction algorithm. If it is then each cycle must start and 
end with a blank measurement. If/when the user interrupts a cycle before its natural end, 
the user will be prompted for a final blank measurement. If Drift Correction is selected, 
the application prompts the user to end the cycle with a blank measurement.

Note: When frequency dependency measurements are required (using the MS2B), and 
Drift Correction is selected, the program must start with a blank measurement. The 
program must include two blank measurements inserted at the point where the frequency 
type changes (e.g. from LF to HF or vice-versa). The program must also end with a blank 
measurement.

Note: When frequency dependency measurements are required (using the MS2B), and 
Drift Correction is not selected, the program needs only one blank measurement when the 
frequency type changes. In this case there is also no need for the program to end with a 
blank measurement.

5.6.3.5. Numbering Format
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The acquired measurements can be displayed in one of three numbering formats (Figure 20).

Figure 20: Numbering format settings

 The format can be selected during the initial report creation steps, or while viewing a report by 
selecting Settings from the Report menu.

•	 Fixed exponent: The exponent is fixed by editing the default value in the box.

•	 Scientific: Numbers are displayed with only 1 digit before the decimal point.

•	 Engineering: Numbers are displayed with exponents consisting of a power of 3.

The number of digits after the decimal point can be selected in the Digits after decimal point 
drop-down box.

Unit selection

In the Physical characteristic drop-down box, select the type of physical characteristic to 
measure (e.g. Magnetic Susc. when using MS2 or MS3 meters).

In the Unit drop-down box, select the unit in which the characteristic should be displayed (e.g. 
‘SI’ or ‘CGS’ for magnetic susceptibility).

5.6.3.6 Depth

This screen lets the user set an automatic depth increment for down-hole or core 
measurements.

Down-hole settings (Figure 21) are available when the selected report type is Core and down-
hole survey. Tick the Automatic Depth Inputs to enable the related controls:



BARTINGTON INSTRUMENTS

	 Page 32 of 54 	 OM2518/1

Figure 21: Down-hole settings

•	 Initial depth in meters: The depth at which the first measurement is taken.

•	 Depth increment in meters: The amount in metres that is added to the depth after each 
measurement is taken.

•	 Auto depth stop: Select this tick-box to ensure that the measurement program is stopped 
when/if the maximum depth value is reached.

•	 Max. depth in meters: The depth (set by the user) at which the program stops taking 
measurements.

Note: Bartsoft will always take an extra measurement if the max. depth has not been 
reached exactly using the specified increments. Therefore, if the max. depth is not exactly 
divisible by the depth increment, the final measurement taken will exceed the max. depth.

5.6.4. The GPS Window

While the ‘Log GPS data’ is selected from the settings window, the GPS window can be accessed 
by selecting Tools → GPS... from the main application menu. See Figure 22. This window enables 
the user to view the current GPS output and also to ensure that there is a GPS fix, before starting 
the measurements (when the GPS data logging is required).

If/when there is a GPS connection, the ‘Number of satelites used:’ should display number 3 or 
larger. The Sys Data and Sys Time will be displayed when Bartsoft is successfully communicating 
with the GPS device, even if there is no signal available.

Note: If the Sys Date/Sys Time are not displayed then there may be an issue 
communicating with the GPS device. See Section 6: Troubleshooting and Tips for more 
information.  
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Figure 22: The GPS window

•	 Sys Date: Displays current date.

•	 Sys Time: Displays current time.

•	 Lat.: Displays current latitude information.

•	 Long.: Displays current longitude information.

•	 Altitude: Displays current altitude information.

•	 Alt. Ellipsoid: Displays current altitude information in relation to the WGS ellipsoid.

•	 Fix quality: Displays the current quality of the GPS signal.

•	 Fix Type: Displays the type of GPS fix being used.

•	 Selection: Displays GPS satellite selection data.

5.7. Taking Measurements

Once the settings have been entered, the software is ready to take measurements. The main 
display is shown below in Figure 23. 

 
 

Figure 23: The Measurement window (List view)

Key to Figure 23

1.

2.8.

7.

3.

4.

5.6.

1. Device Status 

2. Drag header to change column ordering 

3. List view slider bar 

4. Start: Starts the measurement protocol 

defined in Settings → Program.  

5. One Cycle: Runs only the first cycle of the 

measurement protocol.  

6. Graph/List: Switches between the List view 

and the Graph view. 

7. Task & Program progress bars 

8. Drag seperator to change colum width
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5.7.1 Start

When ready to begin taking sample readings, the user should press the Start button. 

A message will appear allowing the user to enter a name to be used to identify the sample being 
recorded (see Figure 24). The Enable ID input for all records box can be ticked to give the same 
name to all samples. A number will be added so each sample can be separated. If this box is 
not ticked then this screen will appear before each sample is taken, and a different name can be 
given to each. 

There will then follow several on-screen prompts depending on the measurement protocol that 
has been defined.

Figure 24: Measurement Start window

5.7.1.1 Blank Measurement

A blank measurement is usually taken at the start, and end, of each cycle of sample 
measurements. The following prompt, shown in Figure 25, is displayed beforehand asking the 
user to remove any sample from the sensor and to measure an air value.
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Figure 25: Blank measurement

Pressing OK will begin the measurement.

5.7.1.2 Sample Measurement

Figure 26: Sample measurement

Figure 26 is displayed before the sample measurement is taken. ‘Sample 1’ will be replaced by 
the name of the sample entered previously by the user. The Measure again tick box can be used 
to tell the software that you wish to repeat the previous measurement. The Pause button can 
be used to temporarily halt the measurement and return to the main report screen. Selecting 
the Resume button, which then replaces the Start button, will allow you to carry on with your 
measurements. Pressing Next begins the sample measurement and moves on to the next stage 
in the measurement protocol. 

5.7.1.3 Measurement Progress

The progress bar, shown in Figure 27, fills up as the measurements are carried out. The top 
bar shows the current progress through the entire measurement program. The bottom bar 
shows the progress of the current measurement, when it reaches the end the measurement is 
complete. The time taken for this bar to complete is dependent on the measurement period of 
the sample being taken.
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Figure 27: Measurement progress bar

5.7.2 Measurement Results

After the each sample measurement has been taken it will be displayed as a list in the table as 
shown in Figure 28. Blank measurements are not displayed in the table.

Figure 28: First sample measurement in the list view

Once all samples have been taken and the measurement program has been completed, the 
prompts will end and analysis can be carried out on the recorded values.

5.7.3 Manual Measurement Entry

The Manual Entry window can be used when there is no sensor connected, in order to enter 
measurements maunually. This option becomes available from the main menu by selecting 
Tools → Manual Entry...  when a new or existing document has been opened. The Manual Entry 
window is shown in Figure 29.  Pressing Insert will place the entry in the next row of the table in 
the current document.
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Figure 29: Manual Entry window

•	 Item name: The name or ID for the measurement.

•	 Date/Time: Date and time the record was created. 

•	 Position: The X, Y and depth coordinates of the measurement (if any). Note that X & Y values 
must be separated by a ‘/’. 

•	 Longitude/Latitude: The geographic coordinates of the measurement (if any). 

•	 Value: The measurement value in SI. 

•	 Correction: The correction value for the measurement (if any). 

•	 Note: Notes or comments about the record. 

5.8 The Bartsoft Report Screen

5.8.1. Overview

The different parts of the report fall into three main sections:

•	 Report information (Report Title, File Information, Data Processing Information)

•	 Table of Measurements

•	 Graph.

Pressing the ok button in the top right corner will close the current report. You will be prompted 
to save your data. Pressing the x button when no report has been opened will minimise the 
Bartsoft CE application.

5.8.2 Table of Measurements

The table of measurements displays the acquired measurements in a list format. Users can edit 
some fields or remove the selected record(s) of measurements.

The table consists of column titles, with the records of measurements listed as rows underneath 
(Figure 30):
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Figure 30: Table of measurements 
Note: When GPS is activated, GPS Fix is displayed under the table giving up to date GPS 
information. 

5.8.2.1. Column Titles

These form the first line of a table. Each title describes what the column contains.

Records in the table can be sorted in ascending or descending order. A selected title is displayed 
as highlighted. To change the sort order, the column title should pressed twice in quick 
succession.

Note: Successive double taps on the same column title will cycle between ascending/
descending/default (displayed as it was initially acquired).

The order of columns in the table (except for the Name column) can be changed by dragging a 
column header. Any change to the default order will be lost when the document is closed. 

To increase/decrease the width of a column, drag the border line of the column header. 

5.8.2.2. Measurements

Each line contains all information about a measurement that the users chooses to make visible. 
To change what information is visible, use the Table prop. tab in the Settings menu.

If the width of a given display is insufficient for the number of columns chosen to be displayed, 
then the table’s horizontal scrollbar will enable the user to view hidden columns.
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To select a measurement, press on the corresponding ‘tick’ box next to it. Multiple 
measurements can be selected by ticking multiple boxes.

To highlight or clear highlighted record(s), press and hold anywhere in the table to bring up the 
table menu and manipulate any measurements that have been selected.

More actions are available by pressing and holding on a record, which then displays the table 
menu attached to the selected measurement.

5.8.2.3. Editing a Field

The Identifier, Comment and Position information of a measurement can be edited by holding 
down on the field, then selecting Edit → Edit Field.

An edit box will appear. Type the new value before pressing the enter button (on the displayed 
keyboard) or touch the screen anywhere outside the edit box to update the field. 

Note: When editing the ‘Position X/Y’ field, the X and Y values must be separated by a ‘/’ 
sign.

5.8.2.4. Repeating a Measurement

When the application prompts the user to take the next measurement, it gives the option 
of repeating the previous measurement. When a blank (air) measurement is repeated, the 
application replaces the previous blank. This means that multiple blanks are not recorded 
within the program database. However, if a sample measurement is repeated, a separate record 
for each repeated measurement is created. Multiple measurements of the same sample are 
expected to be resolved (see Section 5.8.2.5. Resolving Repeated Measurements).

Note: Dual frequency measurements cannot be repeated (this applies to MS2B sensors, 
where ‘Frequency dependent calculation’ is selected).

When prompted to take the next measurement, the user can select Measure again to repeat 
the previous step. Note that the prompt gives the type and measured value of the previous 
measurement, to help in deciding whether to repeat a measurement.

Figure 32 shows some results where the last three values have been repeated. To help identify 
repeated measurements, the background colour is different and the names of repeated 
measurements are appended with ‘*xx’, where ‘xx’ is an auto-incremented number. When 
prompted to take the next measurement, if the user leaves the Measure again box un-checked 
then the application moves to the next measurement. When the user finishes repeating 
measurements, the application prompts that repeated items need to be resolved, before 
continuing with the rest of the program. This is shown in the second window in Figure 31.
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Figure 31: Merging multiple measurements

To postpone resolving repeated measurements, the user can select I will resolve repeats at the 
end, when prompted. Alternatively, it is possible to save a report with repeated measurements 
and resolve them later.

5.8.2.5. Resolving Repeated Measurements

This can be done before taking the next measurement, or at the end of the program of 
measurements.

To resolve or manage repeated measurements, the user can:

•	 remove the highest or lowest value

•	 simply select and delete any repeated item, as with any measurement

•	 merge multiple measurements into one, by calculating their mean value.

To resolve one group of repeated measurements, hold down on any individual measurement 
within the group to display a pop-up menu. To resolve multiple groups of repeats, select at least 
one measurement from each group, before using the pop-up menu. Alternatively, select Edit → 
Manage Repeats from the main menu.

5.8.2.6. Record selection and deletion 

The check boxes in the name column of the table can be used to select/de-select one or many 
records. 
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To select all records, select Edit → Select All from the menu. When all records are selected, a 
tick sign will appear next to this menu item.

To deselect all records when all records are selected, repeat the same step as above. 

To delete records, select Edit → Delete Selected or Edit → Delete All from the menu.

5.8.2.7. Statistics Window

Figure 32: The Statistics window

The statistics window, shown in Figure 32, allows the user to view maximum, minimum and 
average statistics for their data. It can be accessed by pressing and holding on the list screen 
until the menu pops up, then selecting Statistics. Statistics for all measurements can be 
displayed, or if the user has selected certain measurements beforehand then the statistics for 
just these measurements can be displayed. 

The fields shown in the Statistics window are explained below: 

•	 Number of Measurements: The number of measurements included in the statistics.

•	 Time Period: The time period between the oldest and the most recent measurement.

•	 Maximum Value: The biggest corrected value recorded.

•	 Minimum Value: The smallest corrected value recorded

•	 Average Value: The average of all the corrected values recorded.
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•	 Total Deviation: The standard deviation calculated using all the corrected value 
recorded.

•	 Minimum X Axis: The smallest position of values in the X axis. Only applicable to grid 
measurements.

•	 Maximum X Axis: The largest position of values in the X axis. Only applicable to grid 
measurements.

•	 Minimum Y Axis: The smallest position of values in the Y axis. Only applicable to grid 
measurements.

•	 Maximum Y Axis: The largest position of values in the Y axis. Only applicable to grid 
measurements.

•	 Minimum Latitude: The smallest latitude value obtained from the GPS. Only applicable 
to grid measurements.

•	 Maximum Latitude: The largest latitude value obtained from the GPS. Only applicable 
to grid measurements.

•	 Minimum Longitude: The smallest longitude value obtained from the GPS. Only 
applicable to grid measurements.

•	 Maximum Longitude: The largest longitude value obtained from the GPS. Only 
applicable to grid measurements.

•	 Minimum Depth: The smallest depth value.

•	 Maximum Depth: The largest depth value.

5.8.2.8. Exporting Data

The data within a single file, an entire record or number of records can be copied into the 
system’s clipboard. This data can then be pasted into Excel, Word or OneNote Mobile.

To copy data, select the desired record and then click on the table to open the menu. Options are: 
Copy Field, Copy Record or Copy All Selected.

5.6.3. Graphs

The graphs give an overview of all stored measurements. Two types of graph can be selected 
using the Graph Settings window in the Settings menu: 2D Graph and Grid Graph. Selecting the 
List or Graph options in the bottom right hand corner of a report will switch between the two. 

5.8.3.1. 2D Graph

Depending on how measurements are currently sorted, this graph (Figure 33) shows values 
(vertical axis) in relation to position or sample index (horizontal axis). 
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In a line graph the Y axis represents each measurement’s ‘corrected’ value, where the 
measurement with the smallest value is placed at the bottom of the screen and the highest value 
is placed at the top. 

The X axis is calculated simply by incrementing the X value of the previous measurement in the 
list of given measurements. Note that the list of measurements at any given time is sorted in 
ascending or descending order, by one of the fields (e.g. the time-stamp by the default).

Figure 33: 2D graph

5.8.3.2. Grid Graph
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The grid graph is shown in Figure 34. 

Measurements in a grid graph are drawn as rectangles, where the position X and Y of a 
measurement item defines the screen position of the associated rectangle. The bottom left of 
the screen has value zero for both the X and Y axis. The colour of each rectangle is calculated 
according to the value of the measurement that it represents. Each colour has two different 
shades, associated with the highest and the lowest values in the given list of measurements.

Figure 34: Grid graph

5.8.3.3. Graph Controls

The following actions are available while in Graph view:

Selecting an item

Select a measurement item on the graph by pressing the point on the screen. A dotted cross 
shows the currently selected item on the graph. Switch to the list view to identify the selected 
record, which will be highlighted. Conversely, you can select a record in list view and switch to 
Graph view to see the measurement item on the graph. 

Pressing the left and right arrow buttons (key 4 or 8 while in portrait mode, and 2 or 6 in 
landscape mode) causes the previous or next item to be selected (applies to line graph only). 
Note that if the graph is in zoomed mode, then these two buttons have a different functionality 
(see Zoom function). 

Zoom function

Zoom into an area within the graph by drawing a rectangle from top-left to its bottom-right 
corner. The new graph includes the items within the left and right boundaries of the rectangle. 
The zoom function can be repeated up to 50 times to increase the level of visible detail. 
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Zoom steps can be undone by drawing a rectangle in opposite direction, staring from bottom-
right towards the top-left. Unlike the zoom rectangle, the width of the rectangle drawn for ‘undo 
action’ is not significant and it will only return the screen to the previous zoom state. 

While in the zoomed mode, double clicking on the screen will reset the zoom level to zero. 
Pressing the left and right buttons (key 4 or 8 while in portrait mode; 2 or 6 in landscape mode) 
will shift the zoomed area to left or right respectively (applies to line graph only). 

5.8.4 Saving/Loading Reports

The default file storage location on the device is: ‘\My Documents\Bartsoft\’. 

If a Memory Card is present and used as storage, then the same location (‘\My Documents\
Bartsoft\’) is used on the Memory Card (named ‘Storage Card’ by default). 

Note: Any file stored in locations different to the above will not be visible on this list.

5.8.4.1 Saving

A report can be saved at any time by using the File → Save or File → Save As... functions from 
the main menu. Files are automatically saved in the ‘Bartsoft’ folder on your mobile device.

If the user attempts to close a report without saving it first, the message in Figure 35 will be 
displayed asking if they would like to save the data.

Figure 35: Save changes prompt

5.8.4.2 Loading saved Files

Files can be opened from the Bartsoft document view, shown in Figure 36. 
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Figure 36: The load screen

Document view is the default window when the application is started. The displayed list contains 
all application files (if any) with ‘.bid’ extension currently stored on the device. 

It is also possible to open files using the File → Open function from the main menu. However 
only one report can be opened at any time so this function is not recommended.

Note: Using the File → Open function from the main menu at the wrong time can cause 
Bartsoft to crash. This function is unnecessary and should be avoided.

5.8.5 Bartsoft PC Report

The Bartsoft CE display shows a simplified version of the report generated in the PC version of 
Bartsoft, but can be imported into the PC version for presentation purposes. Figure 37 shows the 
report layout on the PC version of Bartsoft.

1.	 Report Title: The name of the file that you are viewing. It is followed by an asterisk (*) if it has 
not been saved since the last modification.

2.	 Data Processing Information: Shows all information used to correct raw data.

3.	 Table of Measurements: Displays all the acquired measurements. The table also lets the 
user edit, remove and add measurements to the document.

4.	 Measurements Graph: Displays all the acquired measurements in a two-dimensional graph 
or grid.

5.	 Minimise/Maximise Controls: Allow the user to hide unwanted information, in order to leave 
more space for important information.

6.	 File Information: Shows all information about the creation of the file. The Note field can be 
edited by double-clicking it with the left button of the mouse.

6

4

5

1

2

3
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Key to Figure 37

1. Report Title 	 4. Measurements Graph

2. Data Processing Information 	 5. Minimise/Maximise Controls

3. Table of Measurements 	 6. File Information

Figure 37: Bartsoft document (report) breakdown

6. Troubleshooting and Tips

6.1. Connecting a Bartington MS3 device to a hand-held device

Unlike the Bartsoft application for PC, Bartsoft CE can only connect to an MS3 device via a USB 
cable (no RS232 connection is fitted).

Use the provided USB cable, which has an MS3 compatible connector at one end.

While the Windows Mobile hand-held device (with USB host compatibility) is running, connect the 
MS3 device using the cable and start the application (unless already running). Assuming there 
is sensor connected to the MS3 device, the application status at the top of the screen should 
display: ‘Bartsoft 1 OK’.

Note: Do not connect an MS3 device to the hand-held, while it is starting up. Connecting 
the MS3 too soon will cause the operating system to prompt for the USB driver name. In 
this case, it is recommended that the device is disconnected and the prompt is cancelled, 
before waiting for the operating system to complete its start-up process. Once completed 
connect the MS3. 

6.2. How to take a simple measurement without any file or program configured

With a working MS3 connected, select Tools→Device from the main menu to open the Device 
window. 

6.3. Manually creating a measurement record

While there is a document open, you can access the Manual Entry window by selecting 
Tools→Manual Entry... from the main menu. 
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6.4. How to clear the error status, displayed at the top of the application window

Reset the MS3 device by disconnecting and re-connecting the USB connection. If this error 
persists, contact the Bartington Instruments sales services. 

6.5. How to Save As/Export an existing document as a different file format

Unfortunately, the current version does not support this functionality. The only way to achieve a 
similar result is by copy-past operation. 

6.6. GPS Troubleshooting

If no GPS location data is displayed in Bartsoft under the GPS window (Start → Tools → GPS), 
then there may be a problem with the GPS setup on the mobile device.

Bartsoft accesses parsed NMEA GPS data from the Windows Mobile GPS driver. This means 
that any mobile device being used will need to have NMEA capabilities in order to use the GPS 
functions of Bartsoft.

Running other applications that use GPS at the same time as Bartsoft has been known to stop 
Bartsoft from recieving GPS information. It is recommended that any other GPS program running 
on the device be shut down if problems arise.

Ensure that the GPS on the device is functioning by closing Bartsoft and running the native GPS 
device application. Ensure you are outside with a clear view of the sky in order to achieve better 
satellite reception. Refer to the manual for the mobile device if any issues arise here.

6.7 Other 

If there are any issues not covered by this section, or the above steps do solve the problem, 
please contact Bartington Instruments directly at support@bartington.com.

mailto:support%40bartington.com?subject=
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Appendix A: Correction Algorithm

Abbreviation Description

cmeas Volume susceptibility of the sample measured (dimensionless)

cvol Volume susceptibility of the sample (dimensionless) 

cmass Mass susceptibility of the sample (m3/kg) 

ccont Volume susceptibility of the container (dimensionless) 

rsamp Density of the sample (kg/m3) 

mtot Total mass of the sample with the container (kg)

mcont Mass of the container (kg) 

vsamp Volume of the sample inside container 

vref Volume of calibration sample used as a reference (m3) 

hsamp Height reached by the sample inside container

href Maximum height within the container 

dsamp Diameter of the sample core

dref Diameter of the coil opening (sensor opening + enclosure thickness) 

The volume specific correction algorithm is:

cvol = (cmeas x (vref / v samp )) - ccont

The height specific correction algorithm is:

cvol = (cmeas x (1 – 0.00002077)

– 0.0042414 x (href - hsamp )

+ 0.0028426 x (href - hsamp )
2

– 0.0003460 x (href - hsamp )
3

+0.0000136 x (href - hsamp )
4 )) - ccont

The diameter specific correction algorithm is:

χvol = (χmeas / (3.45 x ( dsamp / dref )
3 )) - χcont
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The mass specific correction algorithm is:

χmass = χ vol / r samp

Where

rsamp = (mtot - mcont ) / vsamp

Appendix B: Conversions from cgs to SI

For volume susceptibility: 
From SI (dimensionless) to electromagnetic units cgs (dimensionless): 
cvol (SI) = c vol (cgs) x (4π)

For mass susceptibility: 
From SI (m3 / kg) to electromagnetic units cgs (cm3 / g): 
cmass (SI) = c mass (cgs) /1000 x (4π)
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