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1. About this Manual

This document describes the installation, operation and maintenance of the Spectramag-6 
system from Bartington Instruments. It should be read in conjunction with the product brochure 
(DS2519) which can be found found on the product page of the Bartington Instruments at: www.
bartington.com.

Spectramag-6 software can be downloaded from the software page of the website. 

A block diagram showing the Spectramag-6 system can be found on the drawing page.

1.1. Symbols Glossary

The following symbols used within this manual call your attention to specific types of 
information:

WARNING: Indicates a situation in which serious bodily injury or death could result if the 
warning is ignored.

Caution: Indicates a situation in which bodily injury or damage to your instrument, or both, 
could result if the caution is ignored.

This symbol identifies items that must be disposed of safely to prevent unnecessary 
damage to the environment.

Note: A note provides useful supporting information and sometimes suggests how to make 
better use of your purchase.

1.2. Key to Notation Used In This Manual

Menu items, tabs, check-boxes and other selectable (‘clickable’) items displayed in the software 
are shown in this manual in bold letters, e.g. “click on the OK button”.

A sequence of actions is shown using arrows. Hence, for example:

•	 Edit → Copy means “select Edit, then select Copy”.

•	 Control Panel → System and Security → Device Manager means “click on Control Panel, 
then System and Security, then Device Manager”.

Note: The user’s familiarity with different versions of the Windows operating system is 
assumed. Hence, for example, an instruction might be to ‘open Control Panel’ rather than 
a detailed description of the route to follow to get to Control Panel, as these steps will not 
necessarily be the same from one version of Windows to the next.

http://www.bartington.com/Literaturepdf/Datasheets/Data%20Acquisition%20Units%20DS2519.pdf
www.bartington.com
www.bartington.com
http://www.bartington.com/software.html
http://www.bartington.com/Literaturepdf/Drawings/spectramag-6/spectramag-6%20block%20diagram.pdf
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2. Safe Use

WARNING: These products are not qualified for use in explosive atmospheres or life 
support systems. Consult Bartington Instruments for advice.

3. Important Points to Note Before Using the Spectramag-6

3.1. Compatible Sensors

The Spectramag-6 unit is for use only with the devices listed below:

•	 Sensors from Bartington Instruments Ltd listed in the compatibility table at: 
www.bartington.com/product-compatibility.html.

•	 Accelerometers with ICP interface from PCB Piezotronics Inc., e.g. 393A03 (1V/g) or 393B31 
(10V/g).

•	 Microphone 40AE with preamplifier 26CA from G.R.A.S. Sound and Vibration.

Caution: The connection of any other device may cause serious damage and will invalid the 
equipment warranty.

3.2. Install the Software Before Connecting the USB Cable

Caution: The Spectramag-6 software must be installed on your PC before attempting to 
connect the hardware using the USB cable. Connection of the hardware prior to installing 
the software may cause the system to malfunction.

3.3. PC Power Saving Features

Note: PC power saving features (e.g. hibernation, sleep mode, screensavers, etc.) have 
been known to cause problems when using the Spectramag-6 system, and to prevent 
the system from logging data correctly. These features should be disabled whilst the 
Spectramag-6 system is being used. Consult your PC’s documentation for instructions on 
how to do this.

3.4. Accidental Disconnection of the USB Cable

Note: Disconnection of the USB cable whilst the Spectramag-6 system is operating may 
cause the system to malfunction. Should this occur, stop the PC program, reconnect the 
USB cable, wait 15 seconds and then re-start the program.

http://www.bartington.com/product-compatibility.html
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3.5. PC Power Drain

Note: Under normal operation, power is supplied to the Spectramag-6 unit from its 
internal batteries. However, if the Spectramag-6 unit is switched off but connected to a PC 
with the PC switched ON, then power will be drawn from the computer (approx. 240mA). 
For a laptop PC this may affect battery life. Avoid leaving an un-powered Spectramag-6 
unit connected to a laptop PC that is switched on.

3.6. Saving Documents

Note: The My Documents folder should not be used as a location for saving data when 
automatically logging multiple files using the Multiple Acquisition mode. Files can only be 
saved in the My Documents folder manually, for example when a single run is made using 
the Single Acquisition mode.

3.7. Data Sampling – Aliasing

Note: Always use a sampling frequency that is adequately high to avoid aliasing. For 
example, a 60Hz signal caused by mains electricity can contain harmonics of significant 
magnitude up to 240Hz. See Digital Filtering for steps to minimise or eliminate aliasing.

3.8. Compatibility

Note: Version 6 software is compatible with earlier versions. Files created in the earlier 
versions can be opened and post-processed. See also Software.

4. Introduction to Spectramag-6

The Spectramag-6 system, comprising the Spectramag-6 hardware and software, provides a PC-
based, fast, six-channel, 24-bit data acquisition system with data logger and spectrum analyser 
for Bartington Instruments fluxgate sensors, and for industry standard ICP accelerometers 
and microphones. The Spectramag-6 system performs simultaneous data acquisition in all six 
channels and produces both time domain and frequency domain plots showing either slow or 
fast trends for magnetic, vibration and sound data in three axes.

Time-varying information is converted into a frequency spectrum using Fast Fourier Transforms, 
referred to as FFT in the text. When the Spectramag-6 is used as a data logger, time-stamped 
data can be logged (for extended periods), and then retrieved and post-processed in both time 
and frequency domain. The system is software controlled with connection to the user’s PC via 
a USB interface. Prior to data acquisition, the system is configured using the Spectramag-6 
software. A typical arrangement is shown in Figure 1. 
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Figure 1: The Spectramag-6 system connected to a magnetometer and an accelerometer.

The Spectramag-6 software records time and frequency domain data over a wide frequency 
range (see the product brochure for details). Data logging with time-stamping is also provided, 
hence the system functions as a high-resolution data logger for magnetic, vibration and sound 
measurements. The Spectramag-6 software is compatible with 32 and 64 bit versions of 
Windows 7, Windows 8 and Windows 8.1. It is also compatible with Windows 98, Windows NT, 
Windows 2000, and Windows XP 32 bit.

4.1. Input Channels

The six input channels are divided into two groups of three (Input 1 and Input 2) and are marked 
on the front panel of the hardware as follows:

Group Channels Sensor Type

Input 1 X, Y, Z Select all 3 channels as magnetic or acceleration or 
pressure

Input 2 X, Y, Z Select all 3 channels as magnetic or acceleration or 
pressure

A user can activate either or both groups of inputs for data acquisition and display.

Note: sensor types on the three channels of an input group cannot be mixed.
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Valid combinations are:

•	 Two compatible Bartington sensors (on Input 1 and Input 2).

or

•	 One compatible Bartington sensor, and up to 3 accelerometers or up to 3 pressure 
sensors.

or

•	 Up to 3 accelerometer or 3 pressure sensors on one input group and up to 3 
accelerometer or 3 pressure sensors on the other input group.

4.1.1. Magnetometer Inputs

When a compatible Bartington Instruments triaxial magnetometer is connected to the system, 
the X, Y, Z channels correspond to the X, Y, Z axes of the magnetometer. Hence, up to two 
compatible magnetometers can be connected to the Spectramag-6 data acquisition system via 
the two circular 10-way connectors at the front of the unit.

4.1.2. Accelerometer/Microphone Inputs

When connecting an accelerometer or a microphone to the system, the two input groups (Input 
1 and Input 2) can be independently selected for vibration/acceleration or sound/pressure 
measurements. The Accelerometer/Microphone inputs are six separate BNC connectors on the 
front panel. These inputs use ICP interfaces that provide a 4mA constant current source, and are 
compatible with ICP accelerometers and ICP microphone/preamplifier combinations.

4.2. Sensor Ranges

4.2.1. Magnetometer Inputs

The Spectramag-6 system is designed to accommodate the full scale ranges of compatible 
Bartington magnetometers.

4.2.2. Accelerometer/Microphone Inputs

The Spectramag-6 has preset accelerometer input scaling values, or a custom value can be set 
by the user to match the scaling of the sensor being used.

The microphone input has a custom scaling which can be set by the user, to match the mV/
Pascal scaling of the sensor in use.
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4.3. Coupling

4.3.1. Magnetometer Inputs

Magnetometers can be DC or AC coupled to the Spectramag-6 unit via a high-pass filter.

4.3.2. Accelerometer/Microphone Inputs

The ICP interface connectors supply a constant DC current to the sensors. Input coupling is AC.

5. Hardware

A Spectramag-6 system in typical use (say, in an MRI survey) comprises a Spectramag-6 unit, a 
compatible three-axis magnetometer, a connecting cable, a tripod for the magnetometer, a USB 
cable, universal mains adaptor, and up to three accelerometers with optional microphone and 
preamplifier with associated cables. All items can be conveniently accommodated in an optional 
rugged carrying case offered with the Spectramag-6 system. The user’s laptop computer (with a 
USB interface and installed software) completes the system. Connections to the Spectramag-6 
unit for a typical application are shown in Figure 2.

Figure 2: Spectramag-6 external connections.

The Spectramag-6 unit contains power supplies, amplifiers, filters, six simultaneously triggered 
24-bit A/D converters and a USB interface. To allow field work with a laptop computer, the unit 
contains an internal Lithium Ion battery which is recharged via the universal mains adaptor 
supplied. In order to optimise the battery life of any laptop to which the unit may be connected, 
power to the USB interface is provided by the internal battery of the Spectramag-6 unit. In order 
to extend battery operation, magnetometer power is applied only to the sensor group or groups 
selected.
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Figure 3: Spectramag-6 front panel. 

Key to Figure 3
1. Hirose magnetometer connector for input 1 (duplicated for input 2)
2. Input 1 indicator light (duplicated for input 2)
3. ON/OFF switch
4. Battery status indicator light
5. BNC connectors for accelerometers or microphones for input 1 (duplicated for input 2)
6. Charging indicator light
7. Charging socket for mains adaptor
8. USB port

5.1. Power Status and Charging

A power-on switch [3] is situated at the bottom left hand side of the front panel with a 
battery status indicator [4] (Figure 3). When the unit is switched ON, the battery status 
indicator shows green if the battery is fully charged; amber if the charge is low; and red 
if it is very low.

Note: When the indicator shows red, the unit should not be used but should be recharged 
until the indicator shows green.

1 2

3 4 5 6 7 8
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The unit may be operated while recharging. The charging socket for the mains adaptor [7] has an 
indicator [6] that is lit when the battery is being charged.

Note: For prolonged on-site measurements, additional power sources should always be 
provided.

5.2. Controls and Connectors

All the controls and connectors of the unit are on the front panel as shown in Figure 3. The 
input connectors for the sensors are arranged in two groups, each group having one Hirose 
magnetometer connector [1] and three BNC connectors [5] for accelerometers or microphones.

A compatible three-axis magnetometer or up to three accelerometers or microphones may be 
connected to each input group. The unit provides the power for the compatible magnetometers 
and a constant current ICP interface for the accelerometer and microphone inputs as required. A 
block diagram of the unit is shown on the Spectramag-6 product page.

The BNC connectors (Figure 3) are labelled X, Y and Z to correspond to the allocated data 
channel. A front panel red indicator [2] is lit when power is applied to each group. A USB 
connector is situated at the bottom right hand side of the front panel for connecting to the PC [8]. 

Note: The unit must not be connected to a PC until the Spectramag-6 software has been 
installed.

5.3. Charging the Battery

The battery should be fully charged before use. Connect the universal mains adaptor supplied to 
the Charging socket and apply power. The Charging indicator should be illuminated and should 
change from red to amber to green as the charging progresses.

Note: Adequate charging should be done before use, i.e. the charging indicator should at 
least show the amber colour. Otherwise the performance of the Spectramag-6 system 
cannot be guaranteed.

A full charge takes about 10 hours and the charging will terminate automatically at the end of 
this time, although the indicator will still be illuminated.

See also Maintenance.

6. Software

The Spectramag-6 system is supplied complete with dedicated data acquisition software. 
Consult Bartington Instruments for the minimum hardware requirements and installation 
instructions. 
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A summary of how to use the Spectramag-6 software is given as a flowchart in Figure A.2 - 
see Appendix. Available versions of the Spectramag-6 software can be downloaded from www.
bartington.com/software.html/.

Note: A small change is made to the Spectramag-6 firmware when operated with version 
6.203 of the software or later. After the Spectramag-6 has been run with this version, it will 
be incompatible with earlier versions of the software. However, the change can be reversed 
with a system reset. This is performed by removing the mains and USB cables from the 
unit, and switching the power off. This should be done before connecting the Spectramag-6 
to a different computer and after any re-installation of the software.

7. Connecting Spectramag-6 to the Computer

Note: The Spectramag-6 unit should only be connected to a computer running Windows.

After installing the software, connect the required sensors to the Spectramag-6 unit and switch 
the unit ON using the front panel switch. Connect the Spectramag-6 unit to the PC using the USB 
cable supplied. Windows should detect the instrument automatically. The user will be prompted 
to load device drivers the first time the instrument is connected. The drivers are located on the 
CD but are also installed in the program folder.

1.	 To use the copy on the CD, simply select the drive in the menu and click OK.

2.	 To use the installed drivers, click the option allowing the location of the drivers to be 
specified and browse to the Spectramag-6 installation folder.

Note: The default option is C:\Program Files\Bartington Instruments\Spectramag-6, but 
the program may also be installed at any other location.

3.	 Click on the CIL.inf file and click Open.

Some operating systems may request the driver a second time, hence steps (2)–(3) should be 
repeated. A message may now appear indicating that a new USB device has been found and that 
this is a Bartington Input Device. If shown, these messages should disappear automatically after 
a few seconds. The instrument is now ready for use.

7.1. Connecting Subsequently

After the procedure above has been performed for the first time, the necessary drivers will 
reside in the PC for future use. If the instrument is re-connected subsequently, it will be detected 
automatically and the drivers will be loaded without further intervention. Firstly, connect the 
sensors required, and then switch ON the power to the Spectramag-6 unit. Finally, connect the 
Spectramag-6 unit to the computer with the USB cable. Allow 10-15 seconds for the unit to start 
communications and then start the Spectramag-6 program. See also Operating Practice.

http://www.bartington.com/software.html
http://www.bartington.com/software.html
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7.2. Disconnecting

Carry out the reverse of the connection process. With the Spectramag-6 program closed, disconnect 
the USB cable from the PC before switching off the Spectramag-6 unit. (Disconnecting the USB 
cable when the unit is still ‘live’ will minimise current drain from the computer battery.) See also 
Operating Practice.

7.3. Driver Reinstallation

It may be necessary to reinstall the driver software: for example when the USB cable is 
accidentally disconnected, but the Spectramag-6 unit cannot now be detected despite 
reconnecting the USB, waiting 15 seconds, and running the Spectramag-6 software.

Follow these steps to re-install the device driver:

1.	 Open Control Panel on your PC.

2.	 Go to System → Hardware → Device Manager.

3.	 Double-click on the Universal Serial Controller.

Note: If a (Bartington) USB device is seen with a yellow sign, the driver is not properly 
installed and should be reinstalled.

4.	 Double-click the USB device (with the yellow sign) and click Update Driver. A Hardware 
Update Wizard window opens. Select ‘Yes, this time only’, then click Next.

5.	 Select ‘Install from a list of specified location’, then click Next.

6.	 Select ‘Don’t search I’ll choose a driver to install’, then click Next. 

7.	 Click  on Browse and either go to the location where Spectramag-6 is installed on the PC, or 
go to the folder on the Spectramag-6 CD.

8.	 Click on a file named CIL.inf and click Open. 

9.	 Click Next and click Continue Anyway in the following windows.

10.	Now open the Spectramag-6 software.

If there is still no connection to the Spectramag-6 unit, close the Spectramag-6 program, switch 
OFF the unit and disconnect the USB cable. Switch the unit ON again and connect the USB cable; 
wait 15 seconds and start the Spectramag-6 program. Windows should detect the Spectramag-6 
unit as a Bartington Instrument device. If this is not the case, repeat processes 1 to 9 [because 
some operating systems want this process to be done twice] and restart the PC.
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The above processes should properly install the device driver enabling connection to the 
Spectramag-6 unit.

8. Starting the Software

When the Spectramag-6 unit has been connected and powered up, start the software by 
either double clicking on the Spectramag-6 desktop icon or by selecting Spectramag-6 from 
the Bartington Instruments folder in the Windows Start menu. On start-up, the software will 
automatically detect a connected instrument and list it as BRT01. If there are several items in 
the list then select BRT01, otherwise just click OK to initialise communications. If the instrument 
is not detected on starting the software, select Tools → Detect Instruments from the toolbar 
menu. Alternatively, re-install the driver (see previous section). When the device has been found, 
certain parameters such as the sampling rate, the number of samples etc. need to be set up 
before running a scan.

Data is sampled, processed and displayed under software control using parameters set by 
the user. These parameters are set from menus and saved as default parameters for use in 
subsequent scans. The user can set the inputs to be used, the sampling rate, gain settings, 
input coupling, and display options. To set up the software, click the      ­ icon on the toolbar or 
select Scan → Configure. This brings up the Settings menu. As shown in Figure 4, this has five 
sub-menus that must be used for defining the operation of the software, and an optional sixth 
(Specification) sub-menu. The settings in the Specification sub-menu are only required to set 
Pass/Fail limits for any measurement (see Specification Sub-Menu for further details).

Figure 4: The Settings Menu showing the six sub-menus

The use of each sub-menu is shown in Table 1.

Table 1: The use of each sub-menu.
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Scan Configuration Select input device, coupling, sampling frequency, number of samples, 
filtering, display mode.

Specification Set Pass/fail limits for detecting when a signal reaches a set limit.

Instrument Set-up Set the input gain of the system.

General Specify a location to save their data to, and whether or not data should also be 
saved in ASCII format.

Sensor Set sensor units and scaling.

FFT Select frequency domain parameters such as FFT windows.

The options selected in the six sections of the Settings menu will be saved automatically on exit 
(as default values to use in a run) when the OK button is selected. When a run is completed, the 
settings used in the run are saved for use in the next run. If however the run is terminated (say, 
by stopping the program) then the settings for the most recent completed run will be loaded 
automatically whenever a new run is started. The user can also save these settings to a file by 
clicking the Save Scan Template button in Figure 5. To use an already saved template, click 
Load Scan Template. On selecting the OK button, the unit will automatically set the offset of all 
magnetometer inputs to zero. If the Scan on Exit box (found under the General sub-menu) has 
been selected, a scan will then be initiated automatically when the OK button is clicked. In the 
following sub-sections each of the sub-menus in Figure 4 will be discussed.

8.1. Scan Configuration Sub-Menu

The Scan Configuration sub-menu is the default menu that appears after selecting Scan → 
Configure as shown in Figure 5. The top of the menu is divided into two sections, one for Input 
1 and the other for Input 2. (Input 1 and 2 represent the two input groups of the Spectramag-6 
system, as mentioned in Input Channels.)
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Figure 5: The Scan Configuration sub-menu of the Spectramag-6 software.

8.1.1. Input Mode

At the top of each section is a ‘Use Input’ box for selecting whether or not an input is to be used. 
Tick a box to select an input to be used and leave blank if an input is not required. If a box is 
selected then the Mode, Coupling, Display Type and Display Mode options become live.

For each input selected, the type of input device can be set as a Magnetometer, Accelerometer 
or Microphone via the Mode drop-down menu. Select the appropriate sensors to be connected to 
Input 1 and /or Input 2.

8.1.2. Input Coupling

Because magnetometers have a response containing both DC and AC components, when a 
magnetometer is selected, the coupling to the Spectramag-6 (hardware) inputs can be selected 
as either DC or AC. Hence DC coupling can be used to allow both AC and DC components, or AC 
coupling can be used to only allow AC components.

Accelerometers and microphones however only have AC response; hence, AC coupling is 
the only option that can be selected for these. The DC coupling option is greyed out once the 
Accelerometer or Microphone input is selected. The bandwidth of the accelerometers and 
microphone inputs is limited internally by a high-pass filter with a -3dB point fixed at 0.1Hz 
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regardless of the coupling selected. The selection of AC or DC coupling therefore only applies to 
the magnetometer inputs.

When using a magnetometer input, DC coupling should normally be selected as the default. 
However, if a gain of greater than one is required to view a small AC signal which may be 
superimposed on a large DC magnetic field, then the resulting DC level may cause the 
Spectramag-6’s input amplifiers to saturate, due for example to the background fields. The AC 
response may then be used to remove the unwanted DC input component prior to amplification 
to allow investigation of the AC component only.

Note: The AC input coupling should be used with care as it gives the same appearance 
to the display as the Mean Zero or Offset to Zero display modes described below. The 
difference is that Display Mode (comprising the Normal, Mean Zero and Offset to Zero 
modes: see Display Mode) is used for analysing acquired data containing both AC 
and DC components, and allows the DC component to be added or removed from the 
dataset during analysis. AC coupling filters out DC components permanently during data 
acquisition, i.e. they are removed before recording and cannot be retrieved.

See Acquiring Data, for more on AC and DC coupling.

8.1.3. Display Type

The Display Type menu allows Time Domain, Frequency Domain or Both to be selected for 
display. The display selection can be changed as required after completion of a scan using the 
View option of the display window.

8.1.4. Display Mode

The Display Mode for each input section allows Normal, Mean Zero or Offset to Zero to be 
selected. These apply only to the time domain data but the frequency domain plot will be affected 
by the inclusion or removal of quasi-DC components when Mean Zero or Offset to Zero modes 
are used. The Display Mode selection can also be changed as required after completion of a 
scan.

Normal Mode In the Normal mode the time domain plots represent the real data 
(including both AC and DC components). As a post processing 
feature, one can switch between the Normal mode and the other 
display modes for comparisons.

Mean Zero Mode In Mean Zero mode Spectramag-6 calculates the mean value of 
the X, Y and Z dataset (the sum of all points divided by the number 
of points) and subtracts this from the total value of the X, Y and Z 
dataset.
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Offset to Zero Mode The Offset to Zero mode calculates the mean value of the first 
10 points of an input and subtracts this value from all of the 
individual data points. This causes each trace to start at or near 
the zero line and is useful for measuring/comparing relative 
changes (i.e. excursions) in the three components of the magnetic 
field, or for comparing inputs from different accelerometers/
microphones over a period.

Display Scaling

The Auto Scale box, if ticked, will provide automatic scaling of the graphs to accommodate the 
data. If the box is not ticked, the maximum and minimum values for the Y-axis must be specified. 
Note that the values to be entered in the box will be multiplied by the scaling set (from the 
Sensor sub-menu, see Figure 11): hence to set a range, for example, from 0 to 0.08mT when 
‘mT’ is checked in the Sensor sub-menu, enter ‘0’ and ‘0.08’ as the Y Minimum and Y Maximum 
respectively. This allows scans to be run with the same scale for comparisons. The Auto Scale 
enable/disable feature only works on the time domain plots; i.e. the ranges of the frequency 
domain plots are set automatically by the program.

Additional Display Settings

If a magnetometer is selected for an input then the Show Total Field box can be ticked. This will 
cause the total field to be calculated from the square root of the sum of the squares of the three 
field values and displayed as a fourth component. This can be used in combination with the Show 
Components box to display the individual components and/or the total field. If magnetometers 
are used for both inputs then ticking the Differential / Gradiometer box will cause the graph for 
Input 1 to remain unchanged, but in place of the plot for Input 2, an Input2 – Input 1 graph will be 
displayed showing the difference between the magnetometer inputs.

Note: The number of data-points should be limited to 100,000 points when using both the 
Show Total field and the Differential/Gradiometer option.

8.1.5. Digital Filtering (Pre-Processing option)

Two radio buttons and a check box are grouped under ‘Digital filtering’ in the Scan 
Configuration sub-menu.

The two radio buttons available are:

1.	 None. If selected, no digital filtering is applied to the acquired data prior to it being displayed 
in time and/or frequency.

2.	 Low Pass. This button causes a variable Moving Average low-pass filter to be applied to the 
data (Figure 6). The number of points to use for averaging is set using an up-down arrow 
labelled ‘Number of Rolling Points’ (NRP). The cut-off frequency of the filter is given in the 
text box labelled ‘Cut Off Frequency’ and depends on the sampling frequency and the NRP. 
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The low-pass filter can be used generally for reducing the appearance of power line signals 
(e.g. 50Hz or 60Hz) when for example only slow magnetic trends are of interest. This filter is 
applied to the incoming data in real-time, therefore information above the cut-off frequency 
will be permanently lost.

Figure 6: An acquired signal in a noisy environment. (6a) With the low-pass filter OFF, the noise obscures the desired signals. (6b) The effect of 
applying a low-pass (fcut-off = 2Hz).

Note: The low-pass filter is not primarily an anti-aliasing filter, given that it is a software 
filter positioned after (not before) the A/D converter. As such, signals must be sampled 
fast enough (at least at two times the highest frequency component in the input signal, 
according to the Nyquist criterion) in order to have them resolved in frequency. Once the 
correct sampling frequency is used (i.e. no aliasing), the following low-pass filter is used 
to eliminate unwanted signals from the displayed frequency spectrum. Where the user 
suspects that aliasing will be a problem, the Data Averaging feature should be used to 
reduce this effect.

Data Averaging

When Data Averaging is selected, the system will use multi-rate sampling to minimise aliasing 
effects. When the Data Averaging check box is ticked, and data sample interval is 1ms or longer, 
the system is forced to acquire data at a higher sampling frequency. Data is then averaged and 
final data is stored at the rate selected by the user. This multi-rate sampling is not apparent to 
the user and no allowance needs to be made for it. Its purpose is simply to minimise the aliasing 
effects that can occur where simple sampling is used, and frequencies above the Nyquist 
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frequency are present in the signal being measured. This often occurs in the investigation of low 
frequency signals, with 50 or 60Hz present.

If a sample interval of longer than 1ms is selected, and Data 
Averaging is not checked, then the system will issue a warning 
that aliasing is a danger (right).

If the user responds ‘Yes’ then the scan will commence, but 
multi-rate sampling will not be used; data is acquired at the 
sample rate specified by the user, and aliasing may occur if 
frequencies above the Nyquist frequency are present.

Data Averaging can be used with or without the other digital filter settings.

8.1.6. Observing DC Trends

The following steps should be taken for setting the filter values. Let us assume for example that 
a slow signal of frequency between 0.1–5Hz is to be acquired:

(a) Set the sampling frequency to a minimum of 10Hz according to the Nyquist criterion 
(i.e. set Max Frequency to 5 in the Spectramag-6 program).

(b) Adjust NRP using the up-down arrow to set the cut-off frequency below the power line 
frequencies (50 or 60Hz). The cut-off frequency decreases as the NRP is increased.

To reduce the effect of power line signals substantially in the time domain plots (in order to 
observe DC trends, for example during site surveys), the cut-off frequency should be set, say, 
between 1.5–10Hz. The effect of applying the low-pass filter is shown in Figure 6.

8.1.7. Acquiring AC signals

The key requirement in this case is to set the sampling frequency to a minimum of twice the 
maximum frequency in the signal according to the Nyquist criterion. The Nyquist criterion must 
be met at all times to avoid aliasing. Assuming that a signal of 200Hz needs to be acquired:

(a) Set the sampling frequency to a minimum of 400Hz according to the Nyquist criterion (i.e. 
set Max Frequency to 200 in the Spectramag-6 program).

(b) Adjust the NRP using the up-down arrow to set the cut-off frequency above the desired 
signal frequency, say to 300Hz, or turn the low-pass filter OFF.

8.1.8. Setting Acquisition Modes

Data can be acquired using three different acquisition modes:

1.	 Single.

2.	 Continuous.
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3.	 Multiple.

Table 2 shows the parameters that need to be set for each data acquisition mode.

Table 2: Parameters that need to be set for each data acquisition mode

Acquisition 
mode Max Frequency No of Samples No of Averages No of Runs

Single ü ü ü --

Continuous ü -- Set to 1 --

Multiple ü† ü   -- ü

       ü =  Needs to be set              --  =  Not used

Single Mode The Single data acquisition mode, as the name implies, is used to 
execute a single run of the program to acquire data once. As shown 
in Table 2 the user needs to set the sampling frequency (fsamp) by 
setting Max Frequency (which is fsamp/2), the number of samples and 
the number of averages. The acquired data can be manually saved 
by selecting File → Export → Data and selecting the location and 
the name of the data file to be created.

Continuous Mode The Continuous mode provides a data logging facility for acquiring 
very low frequency signals in the order of 0.1Hz or less (such as 
seismic waveforms etc). This function is activated by checking the 
Continuous Acquisition box. During continuous data acquisition 
the maximum sampling frequency is 0.2Hz, corresponding to a 
sampling period of 5 seconds. Data can be saved at the end of a 
run (or by stopping the program using the r icon on the toolbar) by 
selecting File → Export → Data and selecting the location and the 
name of the data file to be created.

Multiple Mode The Multiple mode feature allows continuous data logging to be 
accomplished by the Spectramag-6 software. The user has to set the 
sampling frequency fsamp (by setting Max Frequency which is fsamp/2); 
the number of samples (N); and the number of runs (R).

A minimum of 2 runs is required when using the Multiple mode. In 
this mode, data is continuously logged to the hard disk as multiple (R) 
data files with each file containing N data points. The data in each file 
is also time-stamped to aid future analysis. It has been estimated that 
the dead-time between consecutive files is approximately 2 seconds. 
This test was done using an AMD Athlon, 64 X2 Dual Core, 2.01GHz, 
1GB RAM computer.



BARTINGTON INSTRUMENTS

	 Page 25 of 68 	 OM2021/9

Note: In Multiple mode, data is automatically logged to the hard disk as .sm6 files and as 
ASCII files if this option is selected under the General sub-menu. The location of the data 
files is specified by clicking the General sub-menu as shown in Figure 10.

Sampling Frequency

Ticking the Use Sample Frequency box lets you set the sampling frequency for each scan 
as a frequency value ‘f’. Values can be entered into the Max Frequency box. This is half the 
sampling frequency, i.e. Max Frequency = fsamp/2. The Max Frequency also represents the Nyquist 
frequency, hence the range of the frequency domain plots is from zero up to Max Frequency.

Leaving the Use Sample Frequency box unchecked means you must specify the sampling period 
(T = 1/f). If the Use Sample Frequency box is not ticked, the Sample Interval box is then activated 
from where sampling period (T = 1/f) values can be chosen ranging from 100mS to 10S.

Number of Samples

The Spectramag-6 system allows a maximum of 700,000 data points to be acquired during each 
scan, both for normal scan and continuous data acquisition. The number of samples to be used 
for a scan is set by entering a value in the Number of Samples input box.

Number of Averages

The Number of Averages dialogue box sets the number of scans to be averaged for the 
frequency domain display.

Note: The time domain display is not averaged and the display shows the latest scan.

Selecting a number of averages (say, N greater than one) will increase the scan time by N times 
but the averaging reduces the noise in the spectrum plot by integration.

Number of Runs

This is used only when Multiple data acquisition mode is selected to set how many completed 
acquisition runs the program should make. Given that a file is saved at the end of each run, this 
feature also sets the number of complete data files that should be produced/logged to the hard 
disk.

Save/ Load Scan Template

Clicking the Save Scan Template button allows a user to save (as a .smt file) all the settings 
made by the user (in all the Settings sub-menus). This could be a set of favourite settings for 
a particular test. To load a saved template, click the Load Scan Template button, select the 
template file to be loaded and click OK to load the template.

Note: The OK button MUST be clicked to load a template properly.
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8.2. Specification Sub-Menu

The Specification sub-menu lets the user set values (for time or frequency domain or both) 
that will cause a test to fail when exceeded. The user-defined pass/fail limits apply to all 
input groups. The values set might correspond to acceptable magnetic field, vibration or 
sound levels during a test, or in the case of an MRI site survey, might correspond to an 
equipment manufacturer’s specification. A pass/fail limit is set from the Scan → Configure → 
Specification tabs as shown in Figure 7.

Note: To use the Pass/Fail feature, set the Display Mode (Display Mode) to Offset to Zero to 
display only the true amplitude of the signal detected, i.e. without showing DC offsets.

Figure 7: Setting the Pass/Fail limits in the Spectramag-6 software.

A test pass or fail is indicated at the bottom of the output display. From Version 6 of the software, 
an audible beep is also used to indicate a fail.

8.2.1 Time Domain Specification

The time domain specification is used to set the peak amplitude excursions (about a stable 
ambient value) in time above which a test fails. Such features are desirable in site surveys, for 
example, as the acceptable signal level can be set in Spectramag-6 according to the allowable 
limits or according to the desired signal level in a test. This is an important time-saving feature 
given that a user is instantly notified of the failure of a test (at the point of detection). A decision 
can then be made whether to terminate a test or not or to restart a test, say at a new location. 
The maximum excursion is set by ticking the Apply Time Domain Specification checkbox and 
entering the desired value in an input box (Figure 7). The program detects both the positive and 
negative excursions from the ambient (zero signal) level.
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8.2.2 Frequency Domain Specification

This feature is useful for specifying both the amplitude (rms) and the frequency of the 
component to be detected. Both the amplitude and frequency limits are also set using the 
dialogue box in Figure 7, by entering each frequency value and its corresponding amplitude 
value in the Frequency/Hz and Intensity/uT boxes respectively, and clicking the Add button.

Note: The autoscaling feature in Spectramag-6 will set the range of the plot according to 
the value entered for the Pass/Fail test.Hence it is good to have a fair idea of the magnitude 
of the signal to be detected. 

Normally initial tests should be done with various small limits to gauge the size of the signal and 
the proper detection limits can then be set accordingly.

For example: if a limit of 2mT (2000nT) is set and the actual signal acquired/detected is 1nT, then 
the plot will look like a straight line due to the difference in magnitude. To see the measured 
signal, right-click the plot, select Properties → Axis, and set a smaller range e.g. 2nT.

Note: The values entered are listed as Intensity/µT, i.e. the entered values are assumed to 
be in mT. Hence to detect a 10mT (rms) signal, simply enter ‘10’ in the input box. Equally, to 
detect a signal of 50pT (rms) enter ‘ 50E-6’ in the input box.

For effective detection, it is useful to set at least three other points of detection around the value 
of interest. For example, to detect a 16pTrms value at 50Hz, the following values can be set (as 
shown in Figures 7 and 8):

Freq rms to be detected (pT)
48 46
49 16
50 16
51 16

The plot in Figure 8 shows the outcome when the measured signal exceeds the set limit at 50Hz, 
at which point a failure was indicated. Notice that the limits set in Figure 7 are in rms, hence 
rms should be selected [using a drop-down menu under the FFT sub-menu (Figure 12)] when 
displaying the results from the pass/fail tests so that the pass/fail results will also be in rms.
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Figure 8: Test failure when the measured signal exceeds the set limits.

Note: When Time Domain or Frequency Domain Specification is used (and the Display 
Specific Curves option is selected), the auto-scale is disabled and the Maximum Excursion 
that the user specified is used as the plot range. If the range specified is much larger than 
the actual signal then one will only see straight lines. In that case the zoom option should 
be used by holding down the left mouse and dragging a box around an area of interest to 
zoom in. Alternatively a suitable excursion limit should be specified or the Display Specific 
Curve box should not be ticked.

8.3. Instrument Setup Sub-Menu

This sub-menu contains the controls for setting the gain for the magnetometer, accelerometer 
and microphone inputs as shown in Figure 9. The gain may be set to 1, 10, 100 or 1000.

Note: In normal circumstances a gain of 1 should be selected for magnetometer inputs, 
unless AC input coupling has been selected when a gain of 10 or more may be appropriate.
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With a gain of greater than 1 and DC coupling selected, the DC levels due to the geomagnetic 
field may cause the input amplifiers to saturate.

Figure 9: The Instrument Setup sub-menu.

As the accelerometer and microphone outputs contain no DC component, amplification may be 
applied without causing DC saturation of the amplifiers. For a 1V/g accelerometer, a gain of 100 
is appropriate and for a 10V/g unit a gain of 10 is recommended.

Note: If a gain of 1000 is selected, the bandwidth of the Spectramag-6 input amplifiers 
will be reduced from 3.5kHz to about 1kHz (-3dB point). When a gain of greater than 1 
is selected, the software applies an appropriate attenuation to compensate for the gain 
so the values displayed will remain constant at all gain settings. Therefore, if an AC field 
of 10nTrms is applied to a magnetometer then the signal will appear as 10nTrms on the 
display at all gain settings, and the operator does not need to consider the gain factor. 
The amplifiers are positioned before the A/D converter so gain may be used in critical 
applications to increase the signal-to-noise ratio, as the signal will be amplified while the 
internal noise of the A/D converter will not.
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8.4. General Sub-Menu

This sub-menu (Figure 10) lets the user select the Data Folder where data can be exported after 
a scan is completed.

Figure 10: The General sub-menu.

The user can browse to a folder by clicking the ... button. For Single and Continuous acquisition 
modes, the data have to be manually saved on completion of a run (by clicking File → Export 
→ Data and selecting the location and the name of the data file to be created) whereas in the 
Multiple mode the data is automatically saved to the specified location. The data is saved as 
a .sm6 file which contains the data, time and frequency domain plots and the settings used 
in a run. The Multiple mode also has the option of exporting data as ASCII files for use in 
spreadsheets such as Microsoft Excel or in other programs such as MATLAB.

The Scan on Exit box (if ticked) will cause an immediate scan when exiting the Settings menu 
by clicking the OK button. If it is not ticked, a run can be started by clicking Scan → Run in 
the toolbar or by clicking the green tick P symbol. A 2-second delay (when DC coupled) or 
10-second delay (when AC coupled) will be introduced before starting a scan, to allow the 
Spectramag-6 input filters to settle.
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8.5. Sensor Sub-Menu

The Sensor sub-menu (Figure 11) allows a user to select their preferred units for magnetic 
field, vibration and sound measurements. In Units the options for magnetic field are nT, μT and 
mGauss (mG) whilst the options for vibration are μg, mg, g or mms-2. 

Note: Selecting these options will cause the graphics to be displayed in the appropriate 
units. 

The unit for sound measurements is set to Pascal.

Figure 11: The Sensor sub-menu.

The Input 1 and Input 2 Scaling settings allow the correct sensor scaling to be selected. The 
Magnetic scaling corresponds to the available range of Bartington Instruments’ compatible 
sensors from 70mT/10V to 1000μT/10V. There is also a Custom option that lets the user enter a 
custom magnetic scaling (in the Input 1 or Input 2 Custom Scaling boxes), as shown by the red 
arrow in Figure 11. The Vibration box allows the accelerometer scaling to be set to 1V/g, 10V/g 
or Custom. Similar to the Magnetic scaling, selecting the Custom option from the box activates 
Input 1 or Input 2 Custom Scaling input boxes, letting a user enter custom scaling factors for 
the accelerometers connected to each input group of the Spectramag-6 unit. The microphone 
scaling is set via the Microphone input box and the value should be set (as a default) to 50mV/Pa 
to match the recommended microphone specification.
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8.6. FFT Sub-Menu

Spectral analysis in Spectramag-6 is accomplished using a Fast Fourier Transform (FFT) 
algorithm. The spectral plots are produced during data acquisition, and when saved data are 
recalled and post-processed. The following are the key features for spectral analysis using the 
Spectramag-6 software.

8.6.1 FFT Windows

FFT windows are useful for minimising spectral leakage that causes power to leak from each 
spectral component to all other bins. The leakage from strong spectral components often 
completely swamps weaker components, making them hard to detect or resolve in frequency: 
hence FFT windows are extensively used for Fourier analyses. There are five FFT windows in 
Spectramag-6 (Figure 12) that can be selected, namely:

•	 Uniform (None) Window

•	 Bartlett Window 

•	 Hamming Window

•	 Hann Window

•	 Welch Window.

Figure 12: FFT settings for the Spectramag-6 software.
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The choice of an FFT window depends mainly on the signal being processed, the desired 
amplitude accuracy and the required frequency resolution. For example, the Hamming window is 
suited to analysing closely spaced sinusoids and gives the best frequency resolution but not the 
optimal amplitude accuracy.

On the other hand, a Hann window is good for analysing narrowband random signals, 
combination of sinusoids or signals of unknown content. It gives slightly better amplitude 
accuracy but lesser frequency resolution compared to the Hamming window. Hence the choice 
of window depends on the signal being processed and whether the point of interest is signal 
detection or frequency resolution (see Appendix B for further details on FFT windows).

8.6.2. Overlap Processing

FFT windows reduce spectral leakage and improve frequency resolution by forcing both ends of 
an input waveform to zero or near to zero to avoid end-to-end mismatch. However this leads to 
data loss at both ends. 

Note: Overlap processing is a method used to reduce such data loss by recovering the data 
normally eliminated by the tapering ends of FFT window functions. In overlap processing 
a longer data set (more than that required to produce a desired frequency resolution) is 
normally obtained. This data is then broken into segments which are overlapped, windowed 
and FFTed: the results are then combined. In Spectramag-6 the overlap feature can be 
selected by ticking a box as shown in Figure 12. The percentage overlap is fixed at 50%.

The other useful feature in the FFT sub-menu is the Number of Discrete Frequencies (NDF). 
The NDF represents the number of segments that the data set is broken into and allows faster 
data processing by enabling smaller segments of data to be FFTed rather than processing a 
large chunk of data all at once. In Spectramag-6, NDF ranges from 1 to 16. The NDF is used in 
conjunction with overlap processing giving the following possible configurations:

(i) Overlap ON, NDF (set from 1 –16).

(ii) Overlap OFF, NDF (set from 1 –16.)

In (i) the acquired data is broken up into the number of segments set by NDF. Segments are 
overlapped, windowed and FFTed. In (ii) the acquired data is broken up into the number of segments 
set by NDF: these are each windowed and FFTed (without overlapping) and the results are then 
combined. In each case best results are obtained with NDF = 16.

Note: In order to use an NDF greater than 1, enough data must be acquired. This follows 
the formula:

Data points required = 4*NDF*1024

This is summarised in Table 3.
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Table 3: The minimum number of data points required for each NDF

NDF Minimum data 
points reqd. NDF Minimum data 

points reqd.

1 4096 9 36864

2 8192 10 40960

3 12288 11 45056

4 16384 12 49152

5 20480 13 53248

6 24576 14 57344

7 28672 15 61440

8 32768 16 65536

Note: For best performance, NDF used should also be a power of two

8.6.3. Spectrum Selection

The Spectramag-6 software produces two forms of outputs:

1.	 spectral amplitudes in rms and Peak to Peak

2.	 Amplitude Spectral Density (ASD) values in rms/√Hz and Peak to Peak per square-root-Hertz 
i.e. PkPk/√Hz.

Each option is selectable via a drop-down menu as shown in Figure 12.

These four options are available to all input types and measurements. For example, when a 
magnetometer is selected as the input source (Figure 5) and nanoTesla (nT) is selected as the 
unit (Figure 11), the output is displayed as nanoTesla-rms (i.e. nTrms) or nTrms/√Hz based 
on whether rms or rms/√Hz is selected in the drop-down menu in Figure 12. Similarly if the 
accelerometer is selected as the input source and the unit is set to microgravity (mg), then the 
output plot is displayed as mgrms or mgrms/√Hz based on whether rms or rms/√Hz is selected in 
Figure 12. Other units can be selected in a similar manner. Table 4 shows more examples of how 
the units for the graphical plots are selected.

Table 4: Example showing how units for graphical plots are selected.

Input selected 
(Figure 6)

Units selected 
(Figure 11)

Spectrum selected from 
FFT sub-menu 
(Figure 12)

Unit used in plots

Magnetometer mT rms mTrms

Magnetometer mT rms/√Hz mTrms/√Hz

Magnetometer nT rms nTrms

Magnetometer nT PkPk nTPkPk
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Accelerometer mg rms mgrms

Accelerometer mg rms/√Hz mgrms/√Hz

Accelerometer mms-2 PkPk mms-2PkPk

Microphone mV/Pa rms Parms

Microphone mV/Pa rms/√Hz Parms/√Hz

Microphone mV/Pa PkPk PaPkPk

9. Acquiring Data

After the desired settings have been selected, a scan can be initiated by selecting Scan → Run 
from the toolbar or by clicking the green tick P symbol. If the Scan on Exit option is selected 
(from the General sub-menu) then a scan will also be initiated on selecting OK from the Settings 
menu.

When exiting from the Settings menu, a two-second delay will occur (if input coupling is set to 
DC) while the magnetometer zero offsets are calibrated. When an accelerometer, microphone or 
a magnetometer with AC input coupling is selected then the delay is increased to ten seconds to 
allow the input filters to settle. Depending on the signal level, a much longer settling time may 
be required when the highest resolution is needed. Repeated scans will show the filter settling 
with time.

During a scan, the progress can be observed at the bottom-right corner of the screen where the 
number of samples acquired and the number of averages or the number of runs completed are 
shown. If a time domain display was selected for any of the input groups then it will be shown 
and updated about once per second, but there might be a longer delay at low sample rates.

Note: If selected, the frequency domain plots will be displayed only on completion of 
a scan. If averaging has been selected, it will only be applied to the frequency domain 
display.

The time domain display is updated approximately once a second with the latest time data while 
the frequency domain display will be updated with the result of the latest average.

Note: The user’s computer may become slow if too many scans are run and the files are 
left open. Save and close the files not required before running a new scan by doing File → 
Close All.



BARTINGTON INSTRUMENTS

	 Page 36 of 68 	 OM2021/9

A typical Spectramag-6 plot is shown in Figure 13.

Figure 13: Time and Frequency Domain plots from Spectramag-6.

9.1. Quick Summary of Data Acquisition Using DC or AC Coupling

Note: Using the correct physical coupling between the Spectramag-6 system and the 
external sensors is crucial during data acquisition in order to ensure a high fidelity of the 
acquired signal. 

Sensors can be AC or DC coupled to the Spectramag-6 system.

9.1.1. DC Coupling

DC coupling is useful for acquiring very slow varying signals (quasi-DC or DC). A gain of 1 is 
generally suggested to avoid the saturation of the input amplifiers in the Spectramag-6 unit that 
have output ranges of ±10V.

9.1.2. AC Coupling

AC coupling is required when there is a need to measure a small AC signal that requires 
amplification prior to signal acquisition. Very often the desired AC signal is superimposed 
on a large DC offset. If a gain is applied to such a signal, the DC offset will be large (after 
amplification) and may saturate the Spectramag-6’s input amplifiers, which have a maximum 
output range of ±10V. By selecting AC Coupling, the DC offset is removed and a gain can then 
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be applied to the remaining AC signal. The gain setting to use depends on the magnitude of the 
signal to be acquired. It is typically from x10 to x100. If the input signal is a small AC and DC 
signal (say from a magnetometer) or purely an AC signal, then AC coupling should be used and a 
gain of >1 should be used to increase the overall signal-to noise ratio of the system (i.e. the ratio 
of the input signal relative to internal Spectramag-6’s A/D converter noise).

9.1.3. Process of Data Acquisition

Note. When taking a succession of acquisitions with AC coupling, especially where the 
sensor(s) are moved in between acquisitions, the user must go through the settings 
window before each acquisition. This will force the stabilising input process, and prevent 
the introduction of errors in the measurements.

The process of data acquisition using DC or AC coupling in the Spectramag-6 software is shown 
in the following screen-shots Figures 14 (a) – (e) and explanatory notes.

(1) Switch the Spectramag-6 system ON and 
connect sensors to the input(s). Launch the 
Spectramag-6 software:

(i) Click the * sign on the software to see 
the Settings window as shown in Figure 
14a.

(ii) Select which input to use and in the 
Mode box select the sensor to use, e.g. 
‘Magnetometer’.

(iii) Select DC in the Coupling box (if 
Accelerometer or Microphone is selected 
in (ii), the default is AC coupling and this 
box is greyed out).

(iv) Select Both to display both Time and 
Frequency plots, or select either Time or 
Frequency in the Display Type box.

(v) Select Normal in the Display Mode box. (Other options are Mean-Zero and Offset-to-
Zero.)

(vi) Tick the Autoscale box to autoscale the plots or enter custom values in the Y Minimum 
and Y Maximum boxes.

(vii) Tick the Low Pass button to apply a Moving Average Lowpass filter to the time plot 
or select None if no filter should be applied. If Low Pass filter is selected, then enter the 
Number of Rolling points to be used in the Low Pass filter.

Figure 14a. Process of data acquisition.
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(viii) Select Single, Continuous or Multiple acquisition mode (see Setting Acquisition 
Modes).

•	 If Single acquisition is selected: enter the No. of Samples and the No. of Averages.

•	 If Continuous is selected: enter the No. of Averages.

•	 If Multiple is selected: enter the No. of Samples and the No. of Runs.

(ix) Tick the Use Sample Frequency box and enter a value in the Max Frequency box: 
otherwise, enter the sampling period (1/f) to use. The Max Frequency value should be half 
the desired sampling frequency.

(2) The Specification sub-menu (Figure 14b) 
lets the user set the peak excursion of the 
input signal at which a test should fail.

To set values in the time domain, check the 
Apply Time Domain Specification and enter a 
value in the Maximum Excursion box. Values 
entered in the box are considered to be in 
µT. Hence if 7 is entered then the program 
will indicate a fail if a signal of up to 7µT is 
detected.

To set the values for the frequency domain:

(i) Select the Apply Frequency Domain 
Specification.

(ii) Enter a value in the Frequency/Hz 
and Intensity/µT boxes and click Add. 
Up to three values should be added 
very close to the value of interest. For 
example, to detect a 17µT peak at 100Hz, enter three values as shown in Figure 14b.

(iv) Check the Display Specification curves to see the excursion limits set, and click OK.

(3) In the Instrument Setup sub-menu (Figure 14c), set the gain to be applied to the two input 
groups labelled Input 1 and Input 2 of the Spectramag-6 system.

Figure 14b. Process of data acquisition.
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Note: For DC coupling a gain of 1 should 
be used. Applying a gain (>1) with DC 
coupling can cause the Spectramag-
6’s input amplifiers to saturate if, for 
example, the background geomagnetic 
field exceeds ±10V (i.e. the output 
voltage range of the Spectramag-6 input 
amplifiers).

(4) In the General sub-menu (Figure 14d):

(i) Set the location where the file is to be 
saved.

Note: Data is saved automatically in .sm6 
format only when the Multiple mode is 
selected. Additional files are also saved 
automatically in ASCII format if the 
Export ASCII option is selected.

Note: For Single or Continuous mode, 
data can only be manually saved. 
To save all the plots and data for a 
Spectramag-6 scan, use File → Save or 
Save As options. To save only the data or 
plot, do File → Export → Data or Export 
→ Graphics.

(ii) Tick the Scan on Exit box to have 
Spectramag-6 start a run once the OK 
button is clicked. Alternatively a scan 
can be initiated by selecting Scan and 
Run from the Spectramag-6 toolbar or 
by clicking the green tick P symbol.

(iii) Tick the Export ASCII box to have 
scan data exported automatically to the 
specified location in ASCII format. This 
applies only to the Multiple acquisition 
mode which can be selected from the 
Scan Configuration menu.

(5) The Sensor sub-menu (Figure 14d) is broken into three groupings namely: (i) Units (ii) Input 
Scaling and (iii) Custom Scaling.

Figure 14c. Process of data acquisition.

Figure 14d. Process of data acquisition.
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(i) In the Units group, tick the units to be used for magnetic or vibration measurements. 
These settings apply to both Input 1 and 2. Selecting these options causes the plots to be 
displayed in the chosen units.

(ii) In the Input Scaling group select the 
scaling factor for the Magnetic or the 
Vibration sensors or the Microphone.

The Magnetic scaling corresponds 
to the available range of Bartington 
Instruments’ sensors from 70μT/10V 
to 1000μT/10V. Selecting Custom from 
the box activates the Magnetic text box 
under the Input 1 or Input 2 Custom 
Scaling. This enables a user to enter 
custom scaling factors to use with a 
magnetometer.

(iii) The Vibration box allows the 
accelerometer scaling to be set to 1V/g, 
10V/g or Custom. Selecting Custom from 
the box activates Input 1 and Input 2 
Custom Scaling input boxes, enabling a 
user to enter custom scaling factors for an accelerometer.

(iv) The Microphone text box allows a custom scaling factor to be specified for a given 
microphone input.

(6) In the FFT sub-section (Figure 14e) are various windows that can be applied to a data before 
being Fourier Transformed. Select a suitable window. (See FFT Windows and Appendix B for 
further information.)

Tick the Overlap box and set Number of Discrete Frequencies (NDF) to 16.

Note: Enough data points must be acquired during a scan in order to use the NDF feature 
as shown previously in Table 3. So for NDF = 16, acquire a minimum of 65536 data points 
during any run.

Figure 14e. Process of data acquisition.
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10. Viewing Data and Annotating Displays

When a scan has been completed, the plotted data will be shown and the status at the bottom of 
the screen will show the unit to be in the idle state (Figure 15). The display type selection may be 
changed using the View menu item to select or deselect Time or Frequency for each input group. 
In this way one or all displays can be shown, or hidden and later retrieved.

Figure 15: Changing the display modes.

The time domain display mode can be changed (after collecting the data) by selecting Data from 
the toolbar and then selecting Settings. A Settings menu will be displayed, allowing the time 
domain display to be switched between Normal, Mean Zero and Offset to Zero. The sensor units, 
scaling, display and the FFT settings can also be modified. These changes will be reflected in both 
the time and frequency domain graphs. If data has been acquired from a microphone, selecting 
Data and Calculate from the toolbar will allow the mean sound intensity over the frequency range 
to be displayed.

The following operations can also be carried out on each display window by clicking the mouse 
cursor within the selected window.

10.1. Zoom Control

If the cursor is moved to one of the display windows and the left mouse button held down, the 
mouse can be moved to select an area of the graph to be expanded. The scaling will be expanded 
with the graph, allowing accurate measurements to be made over a small section of the original 
display. The process may be repeated several times. To restore the display to the original state, 
click the right mouse button on the display and select Show All.
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When many plots are shown as in Figure 16, the size of each plot can also be adjusted by dragging 
the borders of the plot.

Figure 16: Spectramag-6 plot settings.

10.2. Plot Settings

If the mouse cursor is moved over one of the plots and the right button is clicked, a menu will 
appear offering Show All, Undo Zoom, Properties, Show Cursor, Add Marker, Remove Marker, 
Remove All Markers, Show X, Show Y, Show Z and Show Total Field. After zooming, Undo Zoom 
removes the effect of the last zoom action. When changes are made to the view, e.g. by a series 
of zoom actions, Show All resets the plot to the original state.

10.3. Plot Options

Selecting the Properties item (after right-clicking a plot) opens a new window called Plot 
Options. The Plot Options window has nine sub-menus (Figure 17) that allow additional control 
of plots such as setting plot titles, fonts, plot scales etc. Many of these functions will be reset to 
the default values when the program is restarted. To see the full range of sub-menus, use the 
left and right arrows (34) at the top right corner of the main Plot Options menu.
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Figure 17: Changing plot parameters.

10.3.1. Data Sets

This sub-menu allows the lines and the symbols for each of the three axes on the plot to be 
selected from a range of styles, colours and sizes. The default settings give three narrow 
straight lines in red, blue, green and yellow lines (with no symbols) for the X, Y, Z and total field 
respectively. To change the line properties for each axis, click on the line on the right-hand side 
of Figure 17 and select the properties from the settings on the left-hand side.

10.3.2. Show/Hide

This sub-menu allows the plot for each axis to be shown or hidden, enabling the three axes to be 
viewed individually or together.

10.3.3. Graph Title

The graph title can be edited in this menu to customise the plots for export to reports. Full 
control of fonts, text sizes etc. is provided.

10.3.4. Axis Titles

This sub-menu allows the X and Y axes titles’ font types, sizes etc. to be changed.

10.3.5. Axis

The Axis sub-menu allows the axes scales to be set to linear or logarithmic. The user can also 
input the range of the X or Y axis, or both. Note that the program zooms into the plot when the 
log scale is selected. Use Show All to see the entire plot if required.
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10.3.6. Axis Tick

Use the Axis Tick to set the major and minor tick marks for both X and Y axes. The font type, font 
size and the colour of the labels can also be set from this sub-menu.

10.3.7. Grid Lines

The major and minor gridline styles can be selected from this sub-menu. The user can also select 
different styles, colours and thickness of the grid lines.

10.3.8. Key

The Key sub-menu allows the legend to the X, Y and Z axes to be shown or hidden. The font types, 
sizes and the colours of the legends can also be changed in this sub-menu.

10.3.9. Cursors

The Cursors sub-menu lets the user select two cursors that can be used for measurements for 
each plot. Each cursor may be selected to be visible or not and associated with either the X, Y or 
Z axis.

10.4. Show Cursor

Clicking Show Cursor will cause a cursor to appear at the left edge of the plot. This may be 
moved horizontally across the plot by dragging with the mouse to a point of interest or by using 
the left-right arrow keys (34). When a cursor is moved to any point, it gives the X and Y values 
of the signal at that point. For example, if a cursor is shown for a frequency plot, then the cursor 
gives the frequency and the amplitude of the signal as shown in Figure 18. This enables accurate 
readout of the values of the acquired signals.

Figure 18: Using cursors in Spectramag-6.

To read out the values for any signal, use the up-down arrow keys (56) to switch from the X 
to Y or to the Z signal cursor. The cursor will change colour to the corresponding colour of each 
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signal as the up-down arrow is pressed. If the plot resolution is too coarse then the cursor can 
be left in the region of interest and the zoom facility used to show the detail. The cursor may then 
be positioned with a greater accuracy.

Add Marker (Figure 16) causes a marker to be added to a plot at the position of the cursor. 
It also shows the X and Y values. The cursor may then be moved to another point, or may be 
removed by clicking on the Show Cursor option again. Markers may be removed using Remove 
Marker option. This causes the markers to be removed sequentially starting with the most 
recent. The Remove All Markers option clears all the markers from the current display.

The Show X, Y, Z and Total Field menu items (Figure 16) allow the individual axes to be added or 
removed from the plot by clicking the appropriate line. This allows an individual axis to be viewed 
and analysed during and after data acquisition.

11. Saving and Closing Files

For Single or Continuous acquisition modes, data can be saved in Spectramag-6 format (*.sm6) 
for subsequent retrieval, processing and display using the File → Save or Save As options. A 
single file or all open files may be closed without saving using File → Close or File →Close 
All. If a file is being closed by clicking the Close tab on the top right-hand corner of the Windows 
toolbar, the Spectramag-6 software will prompt the user to save each file before closing it. It is 
good practice to close files when not required as a large number of open files can slow down the 
program.

For Multiple acquisition mode, data is automatically saved as .sm6 files. Data can also be saved 
as ASCII files (in addition to the .sm6 files) if the Export ASCII option is ticked in the General 
sub-menu (Figure 10).

12. Exporting Results

When a file is open, it may be formatted for export to other Windows-based applications. 
Selecting File → Export gives the option of Graphics or Data. Selecting Graphics will show a 
list of the plots available. Click on the relevant plot and select Continue. This will produce a Save 
As menu where the folder and file name can be chosen and the file type selected as a Bitmap, 
JPEG or TIFF. When OK is selected, the image size can be set, the default size being 400 x 600 
pixels. Graphics will be exported complete with any markers applied. These files may be readily 
imported into other applications to produce reports.

Data files are formatted as tab-delimited lines of data with a header showing the starting date 
and time of a scan from the computer’s clock. The data headings are shown as time in seconds 
(from the start of a scan) and as the units selected by the user for the X, Y and Z axes. These files 
may be directly imported into applications such as Microsoft Excel, MATLAB etc. As mentioned 
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previously, for Multiple acquisition mode, data is automatically saved as .sm6 files and data can 
also be saved as ASCII files (in addition to the .sm6 files) if the Export ASCII option is selected.

Note: Ensure that enough storage space is available on the hard disk before using the 
Multiple acquisition mode, especially when acquiring large amount of data. Typically each 
Spectramag-6 file (with 700,000 points) is approximately 87Mb. Each ASCII (.dat) file with 
700,000 data points is approximately 48Mb.

Graphics and data files can also be copied and pasted directly into other applications from the 
toolbar using Edit → Copy.

13. Data Recall and Processing

During data acquisition in Spectramag-6, a pre-filter can be selected enabling certain 
frequencies to be removed from the acquired data prior to it being displayed (see Digital 
Filtering). Additionally, the Spectramag-6 software provides a post-processing feature (Figure 
19) for use when data is acquired without filtering and additional processing is required. This 
enables a user to recall and post-process the acquired data in the following ways:

1.	 Averaging N number of files and displaying the final results.

2.	 Applying a Moving Average low-pass filter to any of the acquired data files. This 
feature is especially useful for filtering out power frequencies and their harmonics, 
e.g. in cases where the features of interest are the DC trends inherent in the acquired 
signal. This is often the case for data acquired in a noisy environment with substantial 
interference from 50Hz or 60Hz power line frequencies or their harmonics.

To post-process the acquired data:

1.	 Click Data → Post Process from the Spectramag-6 toolbar (Figure 19).

Figure 19: The post processing feature in the Spectramag-6 toolbar.

This opens a window allowing the user to select the file(s) to be processed.

2.	 To select a file or files, click on one file and then hold down the Control (CTRL) key and 
select the rest of the files to process. Click Open.
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3.	 The selected files open, showing the Post Processing window as in Figure 20.

Figure 20: The Spectramag-6 Post Processing window.

The Post Processing window is in two parts: (a) Digital Filtering section and (b) Average FFT 
Spectra section. These are discussed in the following sub-sections.

13.1. Digital Filtering

Under the Digital Filtering section the user can select/deselect the post processing low-pass 
filter using the ‘None’ or ‘ Low Pass’ button. When a filter is selected, the Number of Rolling 
Points (NRP) determines the number of points in the data that is averaged to produce the filter 
effect. Adjusting the NRP also sets the cut-off frequency of the filter. The Number of Filter 
Passes (NFP) affects the roll-off rate of the filter. For NFP = 1 one, the filter is applied once to 
the data. With NFP > 1 (say, NFP = k) the data is passed recursively k times through the filter. 
This is similar to passing the data through a cascade of k identical filters, leading to a steeper 
roll-off rate. Figure 21 shows data before and after applying a filter.
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Figure 21: (a) Data acquired in a noisy environment and (b) the data after low-pass filtering.
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13.2. Averaging FFT Spectrum

The Average FFT Spectra box (when selected) causes the Spectramag-6 program to produce the 
average of the N Spectramag-6 (.sm6) files selected by the user. The example in Figure 22 shows 
two signals (a) and (b) and the result after averaging in (c).

Figure 22: Signals from two logged data files (a) and (b), and the result (c) of averaging the two signals using the post processing Average FFT 
Spectra feature.

13.3. Only Display Final Data Set

This option is ticked to prevent many windows opening up when many files are post-processed in 
Spectramag-6. Ordinarily, when N files are selected for post processing, these files will open up 
in N different windows, but as many files can cause the software to become slow it is preferable 
not to open all the N files. By selecting the Only Display Final Data Set option, only the final 
window will be opened showing (for example) the average of the N files.

Note: In normal use, the Only Display Final Data Set should always be ticked so that only 
the final result of data averaging or filtering can be seen.

For limited number of files (≤ 20) the Only Display Final Data Set can be deselected. To see the 
opened N files, click the ‘Restore Down’  symbol in the Windows toolbar. With N files open, 
the user can browse through the files to see the evolution of the time data or the frequency 
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components in the frequency domain as shown in Figure 23. These mimic the Joint-Time Fourier 
Analysis, e.g. the Short Time Fourier Transform (STFT) analysis where successive Fourier 
transforms are stacked in time.

Figure 23: Opening multiple windows in the Spectramag-6 software.

14. Operating Practice

If an accelerometer or microphone or a magnetometer (with AC coupling) has been selected as 
the input device, a 10-second delay will be applied to allow the internal filters to settle.

Note: In order to obtain the best results, allow a few minutes for the system to warm up 
and the filters to settle before data acquisition.

The magnetometers are powered whenever connected to the Spectramag-6 unit but the ICP 
interface is powered down when accelerometers are not selected for input.

Note: When closing down, close the Spectramag-6 program before disconnecting the USB 
cable and then switch off the Spectramag-6 unit. Always ensure that the unit has been 
switched OFF before packing it away to avoid completely discharging the battery.

15. Interpretation of Results

In common with all data acquisition systems and spectrum analysers, care should be taken in 
interpreting the results obtained. The time domain display resolution may be much less than the 
number of data points used in a scan and aliasing may therefore occur. This is exactly analogous 
to under sampling and may cause some signals to appear at much lower frequencies than the 



BARTINGTON INSTRUMENTS

	 Page 51 of 68 	 OM2021/9

original signal. Using the zoom control allows a small increment of time to be expanded and the 
true frequency to be seen.

If either the time domain or the frequency domain display appears to show values much 
smaller than the full-scale range, then it is likely that the maximum rms value is not visible 
due to the pixel resolution of the display. This may happen if the number of samples is large 
and the spectral band or the peak signal is narrow. In order to find the maximum values under 
these circumstances, the zoom control should be used to check sections of the spectrum, giving 
a full resolution to the section of the spectrum selected. It is normally better to start with a 
relatively small number of samples to give an estimate of the maximum rms value and then 
increase the number of samples to improve the frequency resolution.

If the spectrum of an accelerometer has high levels at low frequencies, then it may be due to the 
DC offset of the accelerometer amplifiers. Select Mean Zero or Offset to Zero for the Display 
Mode to remove any DC component.

16. Troubleshooting

The system works reliably but bad data can be collected if the USB interface is interrupted or 
initially connected when the Spectramag-6 unit is not switched ON.

To restore correct operation:

•	 close the Spectramag-6 program

•	 disconnect the USB cable

•	 switch the Spectramag-6 unit off for a few seconds

•	 power it up again

•	 connect the USB cable and wait 10–15 seconds before restarting the program.

Bad data may also result from a low battery voltage. If the battery indicator (next to the ON/OFF 
switch) is amber or red then the battery should be charged before use. Additionally, bad data are 
also acquired if the complete system (PC, Spectramag-6 unit, sensors e.g. magnetometers) is 
connected up and the Spectramag-6 software is run without switching on the Spectramag-6 unit.

Note: see also Important Points to Note Before Using the Spectramag-6.

17. Maintenance

The Spectramag-6 unit requires no routine maintenance. Re-calibration of the system by 
Bartington Instruments is recommended at two-yearly intervals.
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17.1 Changing the Battery

The rechargeable Lithium Ion battery needs to be recharged periodically, even if the unit is not in 
use, and will last for approximately 300 charge/discharge cycles. A new battery should be fitted 
every 4 years.

Customers can replace the battery themselves, or it can be done by Bartington Instruments 
every other time that the system is returned as part of its regular service and calibration.

To gain access to the battery, remove the four screws securing the back panel with a 3mm 
hexagonal Allen key. The battery and all internal circuitry are contained in a single assembly 
tray with the battery clamped on top. Carefully pull out the assembly tray (Figure 24a) until the 
battery can be seen on the top of the assembly as shown in Figure 24b.

Note: Care must be taken to avoid stressing internal cables secured to the front panel.

The battery has an indicator showing the state of charge, activated by pressing the button below 
the indicator.

Figure 24a: Internal battery location.

Figure 24b: Battery clamped to top of assembly, with rubber foot attached. [1]

To remove the battery, undo the two screws securing the clamp (Figure 24b) and carefully 
withdraw the battery from the connector on the circuit board. To replace the battery, reverse the 
above procedure.

1
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Note: As shown in Figure 24b, fit a rubber foot on the top of the battery to prevent 
vibrations inside the enclosure when assembled.

17.2. Shipping the Battery in this Equipment

Batteries and equipment containing batteries should only be shipped in accordance with local 
regulations. Refer to the  IATA website (www.iata.org) for regulations regarding air transport.

Caution: If there is any doubt at all as to the integrity of a battery – for example, cracked or 
dented casing – then it must not be shipped. Remove it from the equipment and dispose of 
it according to local regulations.

When changing batteries in this equipment, ensure that the replacement battery is of the same 
type as shown in its brochure, available on the product page.

www.iata.org
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Appendix A

A.1. Spectramag-6 Frequently Asked Questions (FAQ)

A.1.1. Sampling

How do I set the Sampling Frequency?

The sampling frequency is set in two ways. Firstly, when the Use Sample Frequency box is ticked, 
values can be entered into the Max Frequency box. This represents the Nyquist frequency. Note 
that the sampling frequency is twice the value entered for the Max Frequency. Secondly, if the 
Use Sample Frequency box is not ticked, the Sample Interval box is then activated from where 
a sampling period (T = 1/f) value can be chosen, ranging from 100mS to 10S. Note that for most 
systems it is recommended to use 10kS/s (max) for Single mode acquisition and 5kS/s (max) for 
Multiple mode acquisition.

How fast should I sample?

To properly represent and analyse a signal whose highest frequency component is fHz, the 
signal should be sampled at a minimum of 2f samples/second according to the Nyquist sampling 
criterion, in order to avoid aliasing. Sampling a signal at twice its maximum frequency ensures 
that a signal can be properly reconstructed (after processing) and that its frequency can be 
accurately resolved. However, the Nyquist rate does not guarantee the accurate representation of 
the signal’s shape or amplitude. To better capture the shape and amplitude of a signal, it should 
be sampled (as a rule of thumb) at ten times the Nyquist rate, i.e. at 20f samples per second.

How long will each run take?

The duration of a run (in seconds) on Spectramag-6 is obtained by Equation 1. Note that this 
time will vary slightly if say other programs are also running on the computer. It is advisable to 
close all the other programs before running Spectramag-6.

                                    No of samples * n 
Duration of a run =                                      	 (1)
                                   2 * Max Frequency

Where:

•	 Duration of a run is in seconds

•	 n is the number of averages or number or runs set in Spectramag-6

•	 Max Frequency is the maximum frequency value set in Spectramag-6
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How much acquisition time do I get when I use a sampling frequency of fHz?

The acquisition time for a sampling frequency of fHz (where fHz = 2*Mx Frequency) is given by 
Equation 2:

                                          No of samples      
Acquisition time =                                               x N 	 (2)
                                   2 * Max Frequency x N

Where:

•	 N = number of runs

Note that the total acquisition time is not shown on the time domain window as Spectramag-6 
only displays the last scan. It is only shown for the Continuous Acquisition mode (see Setting 
Acquisition Modes).

How do I set the resolution of a frequency plot?

The frequency resolution determines the line width or the width of the FFT bins and is useful 
for setting the level of details (resolution) that can be seen on the frequency scale. For each 
analysis, consideration should be given to the frequency range and the resolution required as 
there is a trade-off between the frequency range/bandwidth and the corresponding frequency 
resolution. In Spectramag-6 the frequency resolution is given as Equation 3.

                                             fsamp
Freq Resolution (Δf) =	 (3)
                                            2048

Where

•	 fsamp = Sampling frequency

For example if the sampling frequency fsamp = 102.4Hz, Δf = 0.05Hz and the range is from 0.05Hz 
to 51.2Hz, then as Spectramag-6 always starts plotting from the second point, the range would 
be from 0.1Hz to 51.2Hz as shown in Figure A.1 (a).

Figure A.1: A diagram illustrating how the resolution of a frequency plot can be chosen.
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Similarly if a maximum frequency of 5kHz (i.e. fsamp = 10kHz) is selected, the frequency resolution 
or line width would be 4.88Hz per bin or per line on the FFT plot, giving a plot ranging from 
9.76Hz–5kHz at 4.88Hz per bin (Fig A.1b).

Note: Be aware that the –3dB point of the Spectramag-6 system (and the frequency plots) 
is at 3.5kHz, or at 1kHz if an input gain of 1000 is selected in Spectramag-6.

What does ‘Max Frequency’ as shown on the Spectramag-6 software represent?

This is the maximum frequency that will be shown on the frequency domain plot. This is 
equivalent to the Nyquist frequency of an FFT plot. Note that the sampling frequency used for 
any scan in Spectramag-6 is twice the Max frequency value set in the program.

What frequency range is used in a plot?

The range of the frequency plot is from DC to Max Frequency/2

How many samples can I acquire using the Spectramag-6 system?

The Spectramag-6 system can acquire a maximum of 700,000 data points per run, for example 
when the Single data acquisition mode is selected. When the Multiple data acquisition mode is 
selected and the user chooses to make N runs and acquire k samples per run, the Spectramag-6 
program produces N files each with k samples.

What is the maximum sampling frequency that I can use for the Spectramag-6 system?

The maximum sampling frequency for the system is 10kHz. This is obtained by setting Max 
Frequency to 5kHz. However care should be taken in interpreting the obtained results as the 
–3dB point of the system is at 3.5kHz. Hence the bandwidth of the system is specified as from 0 – 
3.5kHz. 

Note: Depending on the host PC it is advisable to use a maximum sampling frequency of 
10kS/s for Single acquisition and 5kS/s for Multiple acquisition.

What value should I set for the Number of Discrete Frequencies (NDF)?

Any value from 1–16 can be used but the best results are normally obtained when the Number 
of Discrete Frequencies (NDF) is set to 16. See Table 3 for number of data points required for 
different numbers of NDFs.

A.1.2. Coupling

When do I need to use the AC or DC coupling?

DC coupling is useful for coupling very slowly varying signals (quasi-DC or DC) of relatively 
small amplitudes. Note that AC signals will also be present when using DC coupling. A gain of 
1 is generally suggested to avoid the saturation of the input amplifiers in the Spectramag-6 unit 
that have output ranges of ±10V. If however there is a need to measure a small AC signal that 
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is superimposed on/has a large DC offset, then AC coupling should be used to remove the DC 
component and acquire only the desired AC signal without saturating the input amplifiers in the 
Spectramag-6 unit.

What gain settings should I use?

The gain settings to be used depend on the magnitude of the signal to be acquired. To acquire 
quasi-DC/DC signals, DC coupling should be used with a gain of 1. If the input signal is a small AC 
and DC signal (say from a magnetometer) or purely an AC signal, then AC coupling should be used 
and a gain of >1 should be used to increase the overall signal-to noise ratio of the system (i.e. the 
ratio of the input signal relative to internal Spectramag-6’s A/D converter noise).

A.1.3. Windowing

Which FFT window should I use?

Different FFT windows are chosen based on the types of signals being analysed and whether 
the point of interest is greater precision in determining the amplitudes or the frequencies of the 
spectral components in the frequency domain. Each window has its merits and demerits. Table 
A.1 gives a summary of the different FFT windows available in the Spectramag-6 software and 
their uses. This should be used as a rough guide.

Table A.1: A summary of the FFT windows in Spectramag-6 and their uses

Type of Signal Choice of 
Window

Frequency 
resolution

Amplitude 
Accuracy

Unknown content Hann Good Fair

Narrowband random signal (e.g. vibration data) Hann Good Fair

Sine wave or combination of sine waves Hann Good Fair

Closely spaced sinusoids Hamming Good Fair

Transient & synchronous sampling Uniform Best Fair

Broadband random (white noise) Uniform Best Poor

Random noise Welch Good Fair

Random noise Bartlett Good Fair

A.1.4. Data Acquisition

How do I save data after a run?

Data can be saved by the following actions:

•	 File → Export → Graphics This saves the data plots to a file.

•	 File → Export → Data This saves both the time and frequency domain data to a file.
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Note: Data is automatically saved (as .sm6 files) when using the Multiple mode and 
additionally ASCII files can also be produced when this option is selected (see Setting 
Acquisition Modes). Data can also be saved manually as a .sm6 file using File ->Save As.

Is it possible to connect more that one Spectramag-6 units to my computer?

No. The Spectramag-6 software is designed to support only one Spectramag-6 unit connected 
to the computer via the USB port. Trying to run multiple Spectramag-6 programs or connecting 
more that one Spectramag-6 unit to the PC can cause the system to malfunction.

Where can I find further information on how to use the Spectramag-6 software?

A summary of how to use the Spectramag-6 software is given as a flowchart in Figure A.2. 
Available versions of the Spectramag-6 software can be downloaded from the Bartington 
Instruments website. 
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A.2: Spectramag-6 Data Aquisition Choices Flowchart

.

Figure A.2: Flowchart showing suitable choices for data acquisition using the Spectramag-6 software.
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A.3. Spectramag-6 Do’s and Don’ts

Do:

•	 Uninstall an older version of Spectramag-6 software before installing a new one.

•	 Switch OFF the Spectramag-6 unit, wait 10–15 seconds and restart the Spectramag-6 
program if the USB cable is disconnected during a scan.

•	 Use Offset to Zero to remove DC bias/offset due to background fields in order to see a 
desired trend.

•	 Use the low-pass filter for removing power line signals and harmonics in order to see 
DC trends, for example while using DC coupling during site surveys. Note that the 
Nyquist criterion must be met, i.e. the sampling frequency used MUST be twice the 
minimum frequency content of the input signal.

•	 Close the Spectramag-6 program before disconnecting the USB.

•	 Ensure that there is enough storage space on the hard disk before using the Multiple 
data acquisition mode.

Don’t:

•	 Have other programs running on the PC while running the Spectramag-6 program, 
especially when acquiring data from multiple inputs.

•	 Apply gain while using DC coupling (for magnetometer inputs).

•	 Use Mean Zero if you are interested in slow trends e.g. while using DC coupling.

•	 Under-sample your signal during data acquisition. The Moving Average low-pass filter 
is after the A/D converter, hence it is not suitable as an anti-aliasing filter.

•	 Use low-pass filtering if you are interested in plotting AC signal outside the passband 
of the low-pass filter.

•	 Allow multiple Spectramag-6 program windows to be open at one time. This could slow 
down and also affect the performance of the program.

•	 Tick the Display Specific Curve Box when the Time Domain or Frequency Domain 
Specification is used unless a suitable Excursion limit has been set.

When Time Domain or Frequency Domain Specification is used (and the Display 
Specific Curves option is selected), the auto-scale is disabled and the Maximum 
Excursion specified by the user is used as the plot range. If the range specified is much 
larger than the actual signal then only straight lines will be seen. In that case the zoom 
option should be used by holding down the left mouse and dragging a box around an 
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area of interest to zoom in. Alternatively a suitable excursion limit should be specified 
or the Display Specific Curve box should not be ticked.

•	 Install the Spectramag-6 program on very low spec computers as this will affect the 
performance of the program and can also lead to unpredictable results. See Hardware 
for the minimum computer specification.

•	 Acquire data using the Spectramag-6 system when the Spectramag-6 unit doesn’t 
have adequate charge.

•	 Use Data → Copy when large data has been acquired. Large data should be exported 
to a file by File → Export → Data.

•	 Try to connect more than one Spectramag-6 units to one computer. The Spectramag-6 
system is currently designed so that only one unit can be connected to each computer.
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Appendix B

B.1. Spectral Analysis using Fourier Transforms

B.1.1. Introduction

Most real life sensors and transducers provide signals, usually as a function of time. Such 
signals can be represented visually in equipment such as oscilloscopes, chart recorders etc. By 
representing signals as a function of time it is easy to derive information such as the amplitude, 
period and frequency (for a simple sinusoid). However most real life signals are complex signals 
consisting of a mixture of transients, sinusoids, noise etc. When complex signals are represented 
as a function of time, it is still possible to derive information about the amplitude and duration of 
the complex signal. However it is most often impossible to determine the frequency and there is 
no information concerning the amplitude, frequency and phase of the constituent signals. Such 
information is vital in many engineering disciplines and is essential in determining how systems 
such as amplifiers, filters etc will respond to a particular signal. It is therefore necessary to 
represent complex signals not only as a function of time but equally as a function of frequency. 
This is achieved by Fourier analysis.

B.1.2. Fourier Series and Transforms

One of the key foundations for frequency analysis was laid by Jean Baptiste Joseph Fourier in 
1822 when he stated that any periodic motion can be written as a superposition of sinusoidal and 
cosinusoidal vibrations. This forms the basis of what is now known as Fourier Series (used for 
periodic signals); which was extended to Fourier Transform (to deal also with aperiodic signals); 
then to Discrete Fourier Transform (to deal with sampled/digital signals); and finally to Fast 
Fourier Transform, which is a faster version of the Discrete Fourier Transform.

B.1.3. Processing digital signals

The advent of the digital computer led to the realisation of and the continual drive for 
processing signals digitally – a field now known as Digital Signal Processing (DSP). Most real 
life transducers are analogue in nature, hence the first step to digital signal processing is the 
analogue–to-digital (A/D) signal conversion. This process allows a time-varying analogue signal 
to be represented digitally. During the analogue to digital conversion, a signal is first sampled 
and the values obtained are then represented digitally. The rule for correctly sampling a signal 
was set by the Nyquist theory (according to the work of Harry Nyquist) which stated that to define 
a signal correctly, it is necessary to take at least two samples during each cycle of the signal. If 
the signal consists of a mixture of frequencies then the sampling rate chosen should be at least 
twice that of the highest frequency component. Sampling a signal at twice its frequency ensures 
that a signal can be reconstructed (after processing) and that its frequency can be accurately 
measured. However the Nyquist rate does not guarantee accurate representation of the signal’s 
shape or amplitude. Oversampling the signal at ten times the Nyquist rate is mostly given as a 
rule of thumb.
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On the other hand, if a signal is undersampled, i.e. sampled at less than the Nyquist rate, all the 
signals over half the sampling frequency (the Nyquist frequency) are folded back or mirrored 
back into the pass region according to Equation B1. This is as shown in Figure B.1. Once a signal 
is aliased, it is practically difficult to recover the original signal.
falias = c * fsamp – fsignal        	  (B1)

where:

•	 falias is the alias frequency

•	 fsamp is the sampling frequency

•	 fsignal is the original signal frequency

•	 c is an integer multiple of the sampling frequency such that it is closest to fsignal.

Figure B.1: Aliasing due to undersampling a signal.

B.1.4. FFT windows

FFT assumes the periodicity of any input waveform and the existence of this waveform from plus 
infinity to minus infinity. In reality, waveforms often being processed exist for a fixed duration 
and FFT therefore assumes that a waveform is repeated for all time. If the input waveform 
consists of non-integral cycles, there will be discontinues when it is repeated. Hence FFT sees 
these ‘bogus’ discontinuities that weren’t there in the original signal. The Fourier Transform 
of a signal with these discontinuities produces (along with the spectral components) spurious 
signals spread across all the FFT bins. This causes spectral leakage where power leaks from 
each spectral component to all other bins. The leakage from strong spectral components often 
completely swamps weaker components, making them hard to detect or resolve in frequency. 
The use of FFT windows is therefore necessary to reduce the effect of spectral leakage that 
occurs due to end-to-end mismatch because it is not always possible to guarantee that the 
data being used in an FFT represents an integral cycle of the acquired signal. The following are 
typical scenarios:

1.	 Assume that one desires to perform a 1024-point FFT of a signal. In this case, one can 
acquire 1024 data points of the signal. If the signal is a single periodic sinusoid, the 
sampling rate can be chosen so that complete cycles of the signal can be acquired 
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using the 1024 data points. In reality, most signals that are analysed are complex 
signals consisting of multiple frequencies hence such approach is not useful.

2.	 Using the same example in (i), assuming that a longer dataset of 65536 points was 
acquired and one desires a 2048-point FFT; the 65536 data points have to be divided 
into 32 data segments each of which will be FFTed separately. Again, it is difficult to 
ensure that each 2048 block of data represents a complete cycle of the input signal.

3.	 In some cases (such as noise analysis) it is equally hard to determine the exact period 
of a signal in order to acquire data corresponding to complete cycles of the waveform.

The above points make it useful to window each data before they are FFTed. Different FFT 
windows lead to different amplitude accuracies and frequency resolution, hence an appropriate 
window should be selected depending on the signal being processed. For example the Hamming 
window is good for analysing closely spaced frequencies. It gives the best frequency resolution 
but not the optimal amplitude accuracy. A Hann window on the other hand is good for analysing 
narrowband random signals, combination of sinusoids or signals of unknown content. It gives 
slightly better amplitude accuracy but poorer frequency resolution compared to the Hamming 
window.

Hence the choice of a window depends on the signal being processed and whether the point 
of interest is signal detection or frequency resolution. Another point to note is that a signal of 
finite duration (as mentioned previously) is seen by FFT as a signal of infinite duration to which 
a Rectangular window was applied. As such, even when no generic window function has been 
applied to a signal, due to the finite existence of the signal, FFT assumes that the Uniform (None) 
window has been used. The Uniform (Rectangular or None) window therefore represents a case 
when no window function has been applied.
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B.2.Sampling and Logging Time Estimates

Table B.2 gives estimates of the logging time that can be achieved with different sampling rates 
using the Spectramag-6 software.

Table B.2: estimates of the logging time that can be achieved with different sampling rates using  
the Spectramag-6 software.

Sampling 
rates

Data points 
per run Logging/Acquisition time 

1 Run (sec) 50 Runs 
(hrs)

 100 Runs 
(hrs)

150 Runs 
(hrs)

10kS/s 700,000 70 0.97 1.94 2.92

5kS/s 700,000 140 1.94 3.88 5.83

2.5kS/s 700,000 280 3.88 7.78 11.67

1kS/s 700,000 700 9.72 19.4 29.20 (1.21 
days)

500S/s 700,000 1400 19.4 38.88 (1.62 
days)

58.30 (2.43 
days)

200S/s 700,000 3500 48.6 (2 days) 97 (4 days) 145.8 (6 
days)

100S/s 700,000 7000 97.20 (4 
days) 194 (8 days) 291.66 (12 

days)
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Notes
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